×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    39

    Debug Nokia SyncML client

    Hi All,
    I am the project manager of Sync4j (sync4j.sourceforge.net), an open source SyncML server. I am trying to sync my Nokia 7650 with the server, but I find some difficulties. The main problem is that the 7650 syncml client does not show any information on the nature of the problem. Is there any debug version of the software or development kit/emulator?

    Is there anybody that could give me any SyncML message that the 7650 likes that I can use as reference?

    I am actually reading the init message and sending back a response. But the phone fails giving me no clue.

    Thanks a lot in advance.

    Stefano

  2. #2
    Registered User
    Join Date
    Jun 2003
    Posts
    4

    Same problem with the 3650

    I'm having the same problem with the 3650. Can you post any information you find out?

    Thanks,
    Gary

  3. #3
    Registered User
    Join Date
    Jul 2003
    Posts
    2

    support

    I'm developing a sync server with sync4j, and I've troubled by this problem for several days. Have anyone synchronized with N7650 successfully? Give me some hints please. The sample of encoded server capability which will be sent to phone would be prefered. Thanks a lot!
    Last edited by vegdragon; 2003-07-28 at 08:25.

  4. #4
    Registered User
    Join Date
    Mar 2003
    Posts
    39
    Hi Gary and All,
    the problem was mainly in the encoding of server capabilities. It must be encoded in a opaque well formed document with the devinf encoding. When I fixed that problem, the 7650 started to talk with Sync4j nicely.
    Therefore, now Sync4j can sync with the 7650. Everything is included in the 1.0 version, wich is coming out in few days.

    Stefano

  5. #5
    Registered User
    Join Date
    Jun 2003
    Posts
    4

    Bearer Settings

    I resolved my problem last week as well, but the problem was somewhat different. When I set my "Bearer Type" setting to "Internet", it wouldn't work. Setting my "Bearer Type" to WAP makes the synchronization work.

    I tried this with both TMobile and AT&T SIMs (I'm in Pittsburgh, PA USA). My guess is that TMobile and AT&T WAP gateways do not support WAP 2.0?? Is this what the "Bearer Type" setting is toggling?

    Thanks to all for the help.

    Gary

  6. #6
    Registered User
    Join Date
    Mar 2003
    Posts
    39
    Hi Gary,
    I have seen many strange thinngs between different bearers. That can actually be the problem.

    Stefano

  7. #7
    Regular Contributor
    Join Date
    Jun 2006
    Location
    Pakistan
    Posts
    50

    Re: Debug Nokia SyncML client

    hi, i m developing an application for mobile contact sync using j2me with SyncML and on other side sync4j.

    log shows tht there is some synchronization is taking place,,, in actual no mobile contacts are exchanged or updated.
    guid me how can i get the mobile contacts for s60 n send thm to sync.

  8. #8
    Regular Contributor
    Join Date
    Jun 2006
    Location
    Pakistan
    Posts
    50

    Re: Debug Nokia SyncML client

    anyone can guid me how to sync mobile contacts using syncMLwith j2me. waht abot contacts db in mobiles.

  9. #9
    Registered User
    Join Date
    Mar 2003
    Posts
    4,105

    Re: Debug Nokia SyncML client

    Do not hijack old thread with complete different content. Make it very difficult to answer.

    Are you using your own SyncML client or the classes of Funambol? Have you built your own database on the mobile phone (RecordStore) or are you using the PIM part of JSR-75? Have you tested you MIDlet in one of the Nokia SDKs and monitored the network traffic with the internel tools of the SDKs?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×