×

Discussion Board

Results 1 to 2 of 2

Hybrid View

  1. #1
    Registered User
    Join Date
    Mar 2008
    Location
    Norway
    Posts
    10

    Question Ovi app behaves differently than locally compiled version (Digia Remote Camera)

    I am trying to send email from my N9 without user intervention. After failing over and over I decided to try to find an open source app that did it so that I could examine the source code. The one I chose was Digia's example of a Remote Camera: http://store.ovi.com/content/275567.

    I obtained the source from https://gitorious.org/remote-camera, opened it in QtCreator (latest stable version but I can't remember the version number). After answering the questions about creating files for Harmattan, etc., I compiled it without problems.
    I was then rather disappointed to find that when I ran it on my N9 that I got exactly the same message in the console as I had with my own code. The message was from the send function and said that it could not find the default account.

    When I installed the binary from the Ovi store it worked perfectly.

    So what am I missing?
    Last edited by kwhitefoot; 2013-01-08 at 09:47. Reason: Grammar

  2. #2
    Registered User
    Join Date
    Mar 2008
    Location
    Norway
    Posts
    10

    Re: Ovi app behaves differently than locally compiled version (Digia Remote Camera)

    I posted this same question to a forum at Digia and quickly got a very helpful reply. Look at that thread for the details: https://qt-project.org/forums/viewthread/23626/.

    The short answer is that it does work when used by the actual user, just not when running as the developer user. So the trick is to install it then launch it from the mobile's own UI.

Similar Threads

  1. Replies: 2
    Last Post: 2012-07-22, 04:36
  2. Replies: 2
    Last Post: 2010-10-22, 07:15
  3. Can I retrieve the remote device's specification i.e. OS version??
    By chandrashekar@nexG in forum Symbian C++
    Replies: 6
    Last Post: 2009-02-10, 11:33
  4. device and emulator behaves differently
    By hfoffani in forum Mobile Java General
    Replies: 5
    Last Post: 2006-08-10, 12:20
  5. WTK23 and Nokia 6630 behaves differently
    By unugurn in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2006-01-31, 09:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •