×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    Registered User
    Join Date
    Jul 2012
    Posts
    44

    I have faced problem during sis installation for particular device

    Hello All,

    I am getting problem when i am installing sis file in E-65(for s60 3rd edition).
    The Error is "Required application access not granted". May any one help me about this problem, i am waiting for valuable response from discussion board.

    Thanks

  2. #2
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,143

    Re: I have faced problem during sis installation for particular device

    Basically if it installs to 3rd ed FP2 devies onwards, then its having Location capability, and this capability can not be used with self-signed apps on devices having platform version older than 3rd ed FP2.

  3. #3
    Registered User
    Join Date
    Jul 2012
    Posts
    44

    Re: I have faced problem during sis installation for particular device

    Thank you Sir

    But i have tried with two applications which are Symbian signed in the same device. And it is giving the same error every time.

    Thanks

  4. #4
    Nokia Developer Champion
    Join Date
    Jun 2008
    Location
    Noida,India
    Posts
    3,957

    Re: I have faced problem during sis installation for particular device

    What are the various capabilities included in the project(look for CAPABILITY key word in mmp file, if not known already) & depending upon the same you need to sign the application with a developer certificate or self-signing would do.

    Have a look at the following links, explaining the capabilities & their use cases:

    http://www.developer.nokia.com/Commu...i/Capabilities
    http://www.developer.nokia.com/Commu...ymbian_Signed)

  5. #5
    Registered User
    Join Date
    Jul 2012
    Posts
    44

    Re: I have faced problem during sis installation for particular device

    Hello Vineet

    Thanks for your response.

    Here are details of capabilities from my .mmp file-

    #if SND_HAS_APS || SND_HAS_VAS
    CAPABILITY NetworkServices LocalServices ReadUserData WriteUserData UserEnvironment MultimediaDD
    #else
    CAPABILITY NetworkServices LocalServices ReadUserData WriteUserData UserEnvironment
    #endif

    Is there any thing missing in this?.

    Thanks

  6. #6
    Nokia Developer Champion
    Join Date
    Jun 2008
    Location
    Noida,India
    Posts
    3,957

    Re: I have faced problem during sis installation for particular device

    Ok, And what about the signing part? Are you trying with self-signing or with dev cert.

    NOTE: MultimediaDD will not work with self-signing

  7. #7
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,143

    Re: I have faced problem during sis installation for particular device

    Quote Originally Posted by jai2713 View Post
    Thank you Sir

    But i have tried with two applications which are Symbian signed in the same device. And it is giving the same error every time.

    Thanks
    What actual Symbian signing is used, i.e. are you using Certified signing, express signing or something else ?

    Also Would suggest checking on what actual capabilities are included in the sis file, since your capability statement there has if-clauses, so its not really easy to see.

  8. #8
    Registered User
    Join Date
    Jul 2012
    Posts
    44

    Re: I have faced problem during sis installation for particular device

    Hello Vineet

    I am using it with development certificate and also i have tried it with Symbian signed application also.

    Thanks

  9. #9
    Registered User
    Join Date
    Jul 2012
    Posts
    44

    Re: I have faced problem during sis installation for particular device

    I am using Symbian Signed applications which is done by Symbian on uploading the link-

    https://www.symbiansigned.com/signedui/welcome

    Thanks

  10. #10
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,143

    Re: I have faced problem during sis installation for particular device

    You are then not using symbian signed as such, basically if you say you use symbian signed, then we here would assume that you are using the Express signed or Certified signed, i.e. the commercial signing.

    As you are using developer signing(assuming you also don't have publisher ID either), you do not have possibilities on using MultimediaDD, see more information from:http://www.developer.nokia.com/Commu...Symbian_Signed

  11. #11
    Registered User
    Join Date
    Jul 2012
    Posts
    44

    Re: I have faced problem during sis installation for particular device

    I am using Certified signed Applications on the device and it is showing same error.

    Thanks

  12. #12
    Nokia Developer Champion
    Join Date
    Jun 2008
    Location
    Noida,India
    Posts
    3,957

    Re: I have faced problem during sis installation for particular device

    Something seems to be confusing here. Do you already have a certified signed version of the app you are trying? i suppose you are still developing the application. So is this certified signed app is some other app which you are just trying & you downloaded it from somewhere?

  13. #13
    Registered User
    Join Date
    Jul 2012
    Posts
    44

    Re: I have faced problem during sis installation for particular device

    Hello Vineet

    I am from a Symbian App. Developer Company, so i have many applications which are previously Certified signed from Symbian. And this time i am using another application which is in development phase and send client for testing, and client is using the device and report me the issue. Then i checked it and i got the same, then i tried with Certified signed applicaions on same device (Nokia E65) and all time error is same.

    Thanks

  14. #14
    Nokia Developer Champion
    Join Date
    Jun 2008
    Location
    Noida,India
    Posts
    3,957

    Re: I have faced problem during sis installation for particular device

    Ok, now one more clarification, which was asked in #10 already:

    From where did you got the certificate using which you are signing the application(the same which you have sent to client)? Is it downloaded from SymbianSigned.com, if yes then please login into the account & see if its verified( after logging in, see the top right hand side corner, just adjacent to the 'user name', either 'unverified' or 'verified' must be written)

  15. #15
    Registered User
    Join Date
    Jul 2012
    Posts
    44

    Re: I have faced problem during sis installation for particular device

    Hello Vineet

    All things are right i have tried myself to fix the issue then after i asked in forum. It is downloaded from SymbianSigned.com, and my account is verified and i have generated developer certificate through the particular device IMEI number.

    Thanks

Similar Threads

  1. Problem in installation jad on device
    By mohit28garg in forum Mobile Java Networking & Messaging & Security
    Replies: 1
    Last Post: 2010-01-11, 17:39
  2. [moved] I have faced problem to run s60 application using J2ME
    By sazzad_101 in forum Mobile Java General
    Replies: 2
    Last Post: 2009-11-13, 09:54
  3. Problem faced after SIP setup
    By Flechet in forum Audio
    Replies: 0
    Last Post: 2008-09-12, 05:21
  4. Replies: 7
    Last Post: 2008-03-17, 07:47
  5. App Installation problem on Device using SDK 1.2 version.
    By khurshed79 in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2006-01-12, 08:58

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •