×

Discussion Board

Results 1 to 15 of 15
  1. #1
    Registered User
    Join Date
    Feb 2013
    Posts
    15

    Nokia SDK 2.0 Starting error

    I have 2-3 others eclipse setup (Blackberry android & c/cpp) working fine but for Nokia SDK 2.0 getting strange error... tried many thing... I am on win 8 Full 64 bit.. Both 32 bit & 64 bit java installed tried with single 32 bit java single 64 bit java including / removing path.. but problem remains... any solution ..?

    !SESSION Mon Feb 18 19:22:39 IST 2013 ------------------------------------------
    !ENTRY org.eclipse.equinox.launcher 4 0 2013-02-18 19:22:39.426
    !MESSAGE Exception launching the Eclipse Platform:
    !STACK
    java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
    at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1410)

  2. #2
    Registered User
    Join Date
    Feb 2013
    Posts
    15

    Re: Nokia SDK 2.0 Starting error

    Nokia Web tools also working fine...

  3. #3
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,740

    Re: Nokia SDK 2.0 Starting error

    Some Google hits lead to mystical configuration tips, see http://stackoverflow.com/questions/3...-eclipsestarte, https://bugs.eclipse.org/bugs/show_bug.cgi?id=252425
    Most tools on this site were released earlier than Windows 8, so their compatibility was not checked.

  4. #4
    Registered User
    Join Date
    Feb 2013
    Posts
    15

    Re: Nokia SDK 2.0 Starting error

    not working either .. nokia sdk 2.0 is based on which eclipse ? version no.

  5. #5
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,740

    Re: Nokia SDK 2.0 Starting error

    I do not have it installed, but there may be a .eclipseproduct file in the installation folder. That contains the version number.

  6. #6
    Registered User
    Join Date
    Feb 2013
    Posts
    15

    Re: Nokia SDK 2.0 Starting error

    in my Setup .eclipseproduct file and cofiguration/config.ini both are blank 0 kb files. I am installing SDK from Nokia_SDK_2_0_Java_installer_offline_emd.exe 430467 KB 420 MB file can we have md5 checksome code

  7. #7
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,740

    Re: Nokia SDK 2.0 Starting error

    Having the files completely blank may be a reason for not working the result.
    A thing which pops into my mind: many Eclipse-based tools come in a simple .zip file which you uncompress, however this particular tool is a .exe which you probably install. This leads to the question if it was installed with explicit administrator rights, the thing which in older days happened via right-click + Run as Administrator. If not, there may be a chance that some of the files (exactly the configuration ones) are virtualized, and located in the user profile, something like \users\<you>\AppData\Local\VirtualStore\<path to the original location is replicated here>. If this virtualization happens, chances are that Eclipse can not handle it.

  8. #8
    Registered User
    Join Date
    Feb 2013
    Posts
    15

    Re: Nokia SDK 2.0 Starting error

    you are right config / profile is stored at users/<name>/.eclipse/com.nokia.ide...../ coppied every thing to c:/nokia/ide .. but no solution.... anything other to try ?
    Last edited by jPush; 2013-02-27 at 21:33.

  9. #9
    Registered User
    Join Date
    Feb 2013
    Posts
    15

    Re: Nokia SDK 2.0 Starting error

    i have many working ecpilse setups 1.cpp 2.java 3.qnx blackberry can we have nokia s40 plugin for same.. how to add.. same plugin..

  10. #10
    Registered User
    Join Date
    Feb 2013
    Posts
    15

    Re: Nokia SDK 2.0 Starting error

    tried to follow http://www.developer.nokia.com/Commu...e_installation

    downloaded indigo java but while installing NokiaIDE gor following error


    Cannot complete the install because of a conflicting dependency.
    Software being installed: ndefeatures 1.0.0.201206201112 (com.nokia.nde.ndefeatures.feature.group 1.0.0.201206201112)
    Software currently installed: Eclipse IDE for Java Developers 1.4.0.20110615-0550 (epp.package.java 1.4.0.20110615-0550)
    Only one of the following can be installed at once:
    Java Development Tools Core 3.7.3.v20120119-1537 (org.eclipse.jdt.core 3.7.3.v20120119-1537)
    Java Development Tools Core 3.7.0.v_B61 (org.eclipse.jdt.core 3.7.0.v_B61)
    Java Development Tools Core 3.7.1.v_B76_R37x (org.eclipse.jdt.core 3.7.1.v_B76_R37x)
    Object Teams Development Tooling Core 3.7.3.v_OTDT_r202_201202051448 (org.eclipse.jdt.core 3.7.3.v_OTDT_r202_201202051448)
    Object Teams Development Tooling Core 3.7.0.v_OTDT_r200_201106070730 (org.eclipse.jdt.core 3.7.0.v_OTDT_r200_201106070730)
    Object Teams Development Tooling Core 3.7.1.v_OTDT_r201_201109101025 (org.eclipse.jdt.core 3.7.1.v_OTDT_r201_201109101025)
    Only one of the following can be installed at once:
    Eclipse RCP 3.7.0.v201106131736 (org.eclipse.rcp 3.7.0.v201106131736)
    Eclipse RCP 3.7.0.v201109091335 (org.eclipse.rcp 3.7.0.v201109091335)
    Eclipse RCP 3.7.2.v201202080800 (org.eclipse.rcp 3.7.2.v201202080800)
    Cannot satisfy dependency:
    From: ndefeatures 1.0.0.201206201112 (com.nokia.nde.ndefeatures.feature.group 1.0.0.201206201112)
    To: org.eclipse.jdt.core 3.7.1
    Cannot satisfy dependency:
    From: Eclipse IDE for Java Developers 1.4.0.20110615-0550 (epp.package.java 1.4.0.20110615-0550)
    To: org.eclipse.epp.package.java.feature.feature.group [1.4.0.20110615-0550]
    Cannot satisfy dependency:
    From: EPP Java Package 1.4.0.20110615-0550 (org.eclipse.epp.package.java.feature.feature.group 1.4.0.20110615-0550)
    To: org.eclipse.jdt.feature.group 3.7.0
    Cannot satisfy dependency:
    From: EPP Java Package 1.4.0.20110615-0550 (org.eclipse.epp.package.java.feature.feature.group 1.4.0.20110615-0550)
    To: org.eclipse.platform.feature.group [3.7.0.v20110530-9gF7UHNFFt4cwE-pkZDJ7oz-mj4OSEIlu9SEv0f]
    Cannot satisfy dependency:
    From: Eclipse Java Development Tools 3.7.0.v20110520-0800-7z8gFchFMTdFYKuLqBLqRja9B15B (org.eclipse.jdt.feature.group 3.7.0.v20110520-0800-7z8gFchFMTdFYKuLqBLqRja9B15B)
    To: org.eclipse.jdt.core [3.7.0.v_B61]
    Cannot satisfy dependency:
    From: Eclipse Java Development Tools 3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK (org.eclipse.jdt.feature.group 3.7.1.r371_v20110810-0800-7z8gFcoFMLfTabvKsR5Qm9rBGEBK)
    To: org.eclipse.platform.feature.group 3.7.1
    Cannot satisfy dependency:
    From: Eclipse Java Development Tools 3.7.2.v20120120-1414-7z8gFcuFMP7BW5XTz0jLTnz0l9B1 (org.eclipse.jdt.feature.group 3.7.2.v20120120-1414-7z8gFcuFMP7BW5XTz0jLTnz0l9B1)
    To: org.eclipse.platform.feature.group 3.7.2
    Cannot satisfy dependency:
    From: Eclipse Platform 3.7.0.v20110530-9gF7UHNFFt4cwE-pkZDJ7oz-mj4OSEIlu9SEv0f (org.eclipse.platform.feature.group 3.7.0.v20110530-9gF7UHNFFt4cwE-pkZDJ7oz-mj4OSEIlu9SEv0f)
    To: org.eclipse.rcp.feature.group [3.7.0.v20110216-9DB5Fm1FpBGy_AaVz-mFamgY]
    Cannot satisfy dependency:
    From: Eclipse Platform 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK (org.eclipse.platform.feature.group 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK)
    To: org.eclipse.rcp.feature.group [3.7.1.r37x_v20110729-9DB5FmNFnFLSFCtLxnRfMqt15A4A]
    Cannot satisfy dependency:
    From: Eclipse Platform 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q (org.eclipse.platform.feature.group 3.7.2.v20120207-1839-9gF7UHPDFxGjd-PqDr2jX_4yKaumkoHTz04_q-q)
    To: org.eclipse.rcp.feature.group [3.7.2.v20120120-1424-9DB5FmnFq5JCf1UA38R-kz0S0272]
    Cannot satisfy dependency:
    From: Eclipse RCP 3.7.0.v20110216-9DB5Fm1FpBGy_AaVz-mFamgY (org.eclipse.rcp.feature.group 3.7.0.v20110216-9DB5Fm1FpBGy_AaVz-mFamgY)
    To: org.eclipse.rcp [3.7.0.v201106131736]
    Cannot satisfy dependency:
    From: Eclipse RCP 3.7.1.r37x_v20110729-9DB5FmNFnFLSFCtLxnRfMqt15A4A (org.eclipse.rcp.feature.group 3.7.1.r37x_v20110729-9DB5FmNFnFLSFCtLxnRfMqt15A4A)
    To: org.eclipse.rcp [3.7.0.v201109091335]
    Cannot satisfy dependency:
    From: Eclipse RCP 3.7.2.v20120120-1424-9DB5FmnFq5JCf1UA38R-kz0S0272 (org.eclipse.rcp.feature.group 3.7.2.v20120120-1424-9DB5FmnFq5JCf1UA38R-kz0S0272)
    To: org.eclipse.rcp [3.7.2.v201202080800]

  11. #11
    Registered User
    Join Date
    Feb 2013
    Posts
    15

    Re: Nokia SDK 2.0 Starting error

    tried so many things but unable to make it work .. any one tried on 64 bit windows 8 ..

  12. #12
    Registered User
    Join Date
    Feb 2013
    Posts
    15

    Re: Nokia SDK 2.0 Starting error

    no one ..?

  13. #13
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,740

    Re: Nokia SDK 2.0 Starting error

    Based on the error message, even Eclipse thinks that there are too many installations of itself, so having Windows 8 and installing Nokia SDK 2.0 on it may work without any problems. Then it is even more complicated to have the same issue, however on the other there is a chance that it may arise on any kind of Windows.
    Windows 8 in general is not very widespread yet, that is why there are not too many experiences regarding this issue. Also, developers using Windows 8 may be more focused on Windows and Windows Phone developer tools first.

    Eclipse seems to have command line arguments, that may help with separating the installations (here is a related Google-hit, http://help.eclipse.org/indigo/index...e-options.html)

  14. #14
    Registered User
    Join Date
    Feb 2013
    Posts
    15

    Re: Nokia SDK 2.0 Starting error

    thanks for support ...
    problem is in installation file downloaded new one & problem solved ... working fine now with all java 6 java 7 32 bit & java 7 64 bit..
    I have tried WIndoes 7 (my desk) and windows xp (virtualbox) also for same .. i got exact same error so i thought replacing installation file and worked ..

  15. #15
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,740

    Re: Nokia SDK 2.0 Starting error

    Yes, I remember you asking about the MD5 hash in #6, just unfortunately I am not aware of their availability.

Similar Threads

  1. nfcchat: Error starting NFC target detection on Nokia C7
    By xst in forum Near Field Communication
    Replies: 2
    Last Post: 2011-10-03, 11:26
  2. error on starting app
    By honour88 in forum Symbian
    Replies: 1
    Last Post: 2009-12-03, 13:29
  3. Error in starting VS.NET with NDS
    By funachan in forum Symbian Tools & SDKs
    Replies: 3
    Last Post: 2005-05-24, 09:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×