×

Discussion Board

Results 1 to 3 of 3

Hybrid View

  1. #1
    Registered User
    Join Date
    Jan 2013
    Posts
    7

    Post Nokia Maps API Map lost focus and gone in background

    I loaded Nokia maps in my web page. My webpage contains top frame, content frame and bottom frame. I have loaded nokia map in content frame. Now when i click on top frame & click on map, my map goes blank showing white space. all the controls are still there. I can see zoom bar, map type selector. Even if i right click on map, it shows me name of location. But i can't see the map... I don't know why map goes blank..Please help somebody...

  2. #2
    Regular Contributor
    Join Date
    Aug 2011
    Location
    Berlin
    Posts
    288

    Re: Nokia Maps API Map lost focus and gone in background

    It is difficult to diagnose your problem merely from a description - could you post some HTML and JavaScript code within a [ CODE ]... [ /CODE] section to give more context to your issue?

    The only thing I can think of offhand is that maybe you are missing your App Id and Token - these are Mandatory and the map won't render without them.

  3. #3
    Registered User
    Join Date
    Jan 2013
    Posts
    7

    Re: Nokia Maps API Map lost focus and gone in background

    I am sorry. I can't give you the code, because its divided in 3 different frames and this frames are automatically created by my tool. I know I can get code by "view Source Code" but It is too much lengthy... I have registered in Nokia Maps and I do have my appId & Token. But recently I found that this problem is only happening in IE8 (with XP). In other browsers There is no problem. In firefox it works fine. It also works in IE8 (in Windows 7). So I guess the issue is browser compatibility or some text/css... thanks for responding whoever you are...

    This is some of the beginning of my jsp...
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <title>Nokia</title>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=8">
    <script type="text/javascript" src="http://api.maps.nokia.com/2.2.3/jsl.js?with=maps,places" charset="utf-8"></script>
    <script type="text/javascript" src="../javascript/jquery.min.js"></script>
    <script type="text/javascript" src="../javascript/jquery-ui.min.js"></script>
    <style type="text/css">
    html { height: 100%; }
    body { height: 100%; margin: 0; padding: 0; }
    #NokiaMap
    {
    z-index: 1;
    width: 100%;
    height: 100%;
    }
    #layer05_holder
    {
    z-index: 1;
    position:absolute;
    top:3px;
    right:105px;
    width:563px;
    height:auto;
    margin:auto;
    color: #FFFFFF;
    font-family: Verdana, Arial, Helvetica, sans-serif;
    font-size: 12px;
    text-align: right;
    padding-left: 125px;
    }
    </style>
    <script type="text/javascript">
    nokia.Settings.set(appId, "MYAPPID");
    nokia.Settings.set(authenticationToken, "MYauthenticationID");........
    Last edited by inevitable1988; 2013-02-28 at 13:35.

Similar Threads

  1. Focus gets lost whenever an image is captured
    By pooja_1650 in forum Symbian
    Replies: 3
    Last Post: 2009-12-22, 07:16
  2. Problem with CAknNumberQueryDialog(Lost focus)
    By kimhanh in forum Symbian User Interface
    Replies: 2
    Last Post: 2007-04-27, 09:42
  3. Gain/lost focus
    By fhenni in forum Symbian User Interface
    Replies: 0
    Last Post: 2005-01-15, 13:50
  4. Capturing focus lost on a CEikNumberEditor
    By zipher in forum Symbian User Interface
    Replies: 1
    Last Post: 2002-10-15, 21:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×