×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 16

Thread: My pys60 app

  1. #1
    Registered User
    Join Date
    Nov 2012
    Posts
    11

    My pys60 app

    I packed it with python runtime 2.0.0 and passed QA,It is on Ovi Store now and have five stars.
    http://store.ovi.com/content/346711
    The first version only work in Symbian^3 devices,it will work on all s60 v3 fp2 v5 symbian^3 in next version.
    Last edited by brian woo; 2013-03-17 at 09:01.

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,740

    Re: My pys60 app

    They usually tell the reason.

  3. #3
    Registered User
    Join Date
    Nov 2012
    Posts
    11

    Re: My pys60 app

    #1
    Comments from the QA team:
    Failed QA.
    SUMMARY: The application depend on Component 'Python runtime', but there is no instruction in Description of metadata.
    STEPS TO REPRODUCE:
    1. Download and install the content.
    ACTUAL RESULT: 'Component 'Python runtime' missing. Continue anyway?' is dispalayed while installing. When running the application the following error message appears: 'Update is mandatory for installing Python Runtime & its dependencies. Rerun the application for automatic updates'.
    EXPECTED RESULT: The application is launched and works properly.
    AFFECTED DEVICES: All devices.
    FREQUENCY REPRODUCED: 100%..
    #2
    Dear Publisher,
    Thank you for submitting your content to Nokia Publish.
    Unfortunately, we are unable to sign your content because your content requires capabilities beyond Symbian Express.
    Please submit your content to Symbian Signed.
    It depends on python runtime,I made a package with python runtime and min caps and resubmited to QA.

  4. #4
    Nokia Developer Moderator
    Join Date
    May 2007
    Location
    21.46 N 72.11 E
    Posts
    3,800

    Re: My pys60 app

    Quote Originally Posted by brian woo View Post
    It depends on python runtime,I made a package with python runtime and min caps and resubmited to QA.
    The Nokia store no longer accepts Python apps in my knowledge.
    Pankaj Nathani
    www.croozeus.com

  5. #5
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,740

    Re: My pys60 app

    There can be various Python versions scattered around, #2 suggests that the package may contain a high-capability variant.

  6. #6
    Registered User
    Join Date
    Nov 2012
    Posts
    11

    Re: My pys60 app

    I failed QA for many reasons,but they never told me they do not accept python apps.I made a package with pythone runtime 2.0.0 it look no difrrence to other app.

  7. #7
    Registered User
    Join Date
    Nov 2012
    Posts
    11

    Re: My pys60 app

    Passed 8.0 % Hide

    Countries: 中立
    Languages: 中立
    Devices: Symbian^3 Belle: Nokia E6-00 Belle
    S60 3rd Edition FP2: Vertu Constellation Quest

    Failed 92.0 % Show >>
    There is a surprise today,my python app passed 8%.
    Last edited by brian woo; 2013-03-07 at 10:41.

  8. #8
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,740

    Re: My pys60 app

    Do you know what that 8% is?

  9. #9
    Regular Contributor
    Join Date
    Apr 2012
    Location
    malaysia
    Posts
    262

    Re: My pys60 app

    It should not matter if the app is python or not because it is just a programming language just like qt.As long as it is in sis format,nokia store should accept the app.The only problem is the device need to have python runtime or you could just embed python runtime in the sis.I guess the python would need to be signed before include it in your app.Just a workaround solution,not sure work or not for nokia store but definitely work if the app is self-signed.

  10. #10
    Regular Contributor
    Join Date
    Apr 2012
    Location
    malaysia
    Posts
    262

    Re: My pys60 app

    Only e6 belle and s60 v2 vertu passed only.I wonder how many download you can achieve in a day.

  11. #11
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,740

    Re: My pys60 app

    Self-signed embedded packages are supposed to be rejected.
    What was in this latest submission exactly? Practically I mean the .pkg file.

  12. #12
    Registered User
    Join Date
    Nov 2012
    Posts
    11

    Re: My pys60 app

    I pack my app with python runtime 2.0.0 ,so don't need to install python runtime before install this app.
    This is first time that not failed 100%

  13. #13
    Registered User
    Join Date
    Nov 2012
    Posts
    11

    Re: My pys60 app

    I don't mind how many downloads,just want to share my first app to others,I don't have E6 and vertu,I written this app in my E5-00,and it works correctly in my 603.After I finish this app(the last function is testing),I will write other apps in JAVA.
    Last edited by brian woo; 2013-03-07 at 13:55.

  14. #14
    Registered User
    Join Date
    Nov 2012
    Posts
    11

    Re: My pys60 app

    Quote Originally Posted by wizard_hu_ View Post
    Self-signed embedded packages are supposed to be rejected.
    What was in this latest submission exactly? Practically I mean the .pkg file.
    Thanks,I signed it with my publisher cert and fixed some problems this time.


    And the next function is testing
    http://4.bp.blogspot.com/-K5A6Z3dTeE...tedellipse.jpg

    http://3.bp.blogspot.com/-qbHATejoQX...rvepologon.jpg

    http://4.bp.blogspot.com/-jkU_zd31A4...eziercurve.jpg

  15. #15
    Nokia Developer Moderator
    Join Date
    May 2007
    Location
    21.46 N 72.11 E
    Posts
    3,800

    Re: My pys60 app

    Interesting, please do post your updates here!
    Pankaj Nathani
    www.croozeus.com

Similar Threads

  1. Replies: 4
    Last Post: 2010-12-30, 16:17
  2. Replies: 6
    Last Post: 2010-08-10, 21:34
  3. Replies: 0
    Last Post: 2010-04-02, 15:01
  4. PyS60 Talks #2 : PyS60 Extensions
    By croozeus in forum Symbian
    Replies: 14
    Last Post: 2008-09-15, 14:23
  5. PyS60 1.4.3
    By JOM in forum Symbian
    Replies: 14
    Last Post: 2008-05-02, 02:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×