×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Mar 2013
    Posts
    4

    Angry Error: Deployment optimization failed with error '1104'

    Hi,

    I have Nokia Lumia 820 (finally) so i tried testing my software and it failed, so i checked using blank project the problem is the same:

    Deployment optimization failed with error '1104'.

    Emulator works fine and this happens only on real device.

    I couldn't find any reference to this error number.

    Help,

  2. #2
    Nokia Developer Champion
    Join Date
    Feb 2013
    Location
    Dublin, Ireland
    Posts
    544

    Re: Error: Deployment optimization failed with error '1104'

    Just to rule out the obvious...

    1. Is your device provisioned via the Dev Center?
    2. In VS 2012, when you create a new Blank project for WP8, does it deploy?
    3. Are you using any 3rd party libraries (from NuGet, etc)?

  3. #3
    Nokia Developer Moderator
    Join Date
    Feb 2011
    Location
    Portugal
    Posts
    933

    Re: Error: Deployment optimization failed with error '1104'

    Plus to what theo said, can you provide the full output? The final error may be a result of something else.

  4. #4
    Nokia Developer Champion
    Join Date
    Mar 2013
    Posts
    510

    Re: Error: Deployment optimization failed with error '1104'

    It seems the "Native precompilation" used by WP8 might be the issue. This should normally not even be done when you are using the Debug-Output option. You could check wether the optimization is active for your current build target (Debug/Release) using the information Microsoft is providing here: http://msdn.microsoft.com/en-us/libr...zednativeimage

    If you disable the optimization and still see this error my first attempt then would be to reinstall the SDK.

  5. #5
    Registered User
    Join Date
    Mar 2013
    Posts
    4

    Re: Error: Deployment optimization failed with error '1104'

    @Theo blank solution and blank project, phone is dev unlocked and VS recognizes when screen is locked (i get pin lock error)

    here is the output:
    1>------ Deploy started: Project: PhoneApp1, Configuration: Debug Any CPU ------
    1>Deployment of application to device failed.
    1>Error: Cancelled
    ========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========

    Here is error:
    Error 1 Deployment optimization failed with error '1104'.

  6. #6
    Registered User
    Join Date
    Mar 2013
    Posts
    4

    Re: Error: Deployment optimization failed with error '1104'

    So,
    the problem solution is to reinstall windows phone SDK.

  7. #7
    Nokia Developer Moderator
    Join Date
    Feb 2011
    Location
    Portugal
    Posts
    933

    Re: Error: Deployment optimization failed with error '1104'

    Quote Originally Posted by borist View Post
    So,
    the problem solution is to reinstall windows phone SDK.
    Did you managed to solve your problem that way?

  8. #8
    Registered User
    Join Date
    Mar 2013
    Posts
    4

    Re: Error: Deployment optimization failed with error '1104'

    Quote Originally Posted by joaocardoso View Post
    Did you managed to solve your problem that way?
    yes, this actually happend for second time now, each time SDK reinstall resolved the issue

  9. #9
    Nokia Developer Moderator
    Join Date
    Feb 2011
    Location
    Portugal
    Posts
    933

    Re: Error: Deployment optimization failed with error '1104'

    Quote Originally Posted by borist View Post
    yes, this actually happend for second time now, each time SDK reinstall resolved the issue
    Ok thank you for your feedback.

    I didnt had this issue so far but its nice to know there is a last resort solution. Have you reported this to Microsoft on their connect website? I would recommend you to do so.

Similar Threads

  1. Key deployment error
    By mertama in forum Nokia N9
    Replies: 2
    Last Post: 2011-12-19, 10:37
  2. Deployment failed error ?
    By amsingh in forum Windows Phone General
    Replies: 2
    Last Post: 2011-06-09, 22:03
  3. Error with deployment
    By Tiger79 in forum Mobile Java General
    Replies: 5
    Last Post: 2007-05-02, 17:09
  4. Replies: 5
    Last Post: 2006-09-29, 02:05
  5. ERROR: RCMake failed: (Bitmaps): bmconv.exe failed with code 5
    By Dexterp37 in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2005-09-07, 08:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×