×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Mar 2013
    Posts
    7

    Exclamation resolve problem of "iCoeEnv undeclared(first use this function)"

    Hello Sir,

    I use code to bring application in the background

    TApaTask task(iEikonEnv->WsSession());
    task.SetWgId(CEikonEnv::Static()->RootWin().Identifier());
    task.SendToBackground();

    iCoeEnv undeclared(first use this function)

    Please help me shourt out the problem

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: resolve problem of "iCoeEnv undeclared(first use this function)"

    iEikonEnv is a macro, casting iCoeEnv (which is a CCoeEnv variable in a few classes) to CEikonEnv.
    You are most likely using this code snippet where there is no iCoeEnv variable. But it is not a problem, just use CEikonEnv::Static() instead, just as it is seen in the second line of the snippet.
    So
    Code:
    TApaTask task(CEikonEnv::Static()->WsSession());
    task.SetWgId(CEikonEnv::Static()->RootWin().Identifier());
    task.SendToBackground();

Similar Threads

  1. Why do i get "'EEWidthInPixels' : undeclared identifier" error
    By ViruDoshi in forum Symbian User Interface
    Replies: 2
    Last Post: 2005-12-30, 12:26
  2. "'iCoeEnv' : undeclared identifier"
    By zerglim in forum Symbian
    Replies: 1
    Last Post: 2004-06-18, 11:06
  3. Replies: 0
    Last Post: 2004-04-02, 03:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×