×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jun 2003
    Posts
    6

    Small WAVs on Nokia 7650

    Hello, I was wondering, has anyone here tried using WAV files of size smaller than 2500k on a Nokia 7650?

    Ive found that if you use files smaller than that, they dont play properly. Sometimes the beginning part of the file is played, but mostly you just get a click. This doesnt happen in the emulator (Series 60 Concept SDK 0.3 Beta), only on an actual Nokia 7650. Sound files larger than 3000k seem to always play fine.

    The files Im using are 8 bit, Mono, 11025hz

    Has anyone else experienced this problem?

    Thanks

    Tim

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    3
    yes, I have exactly the same problem. I didn't realize it is linked to the size of the file. I thought it was due to the audio codec (I use IMA ADPCM), but even with changing it, it is the same.

    Anyone has a solution for that??

  3. #3
    Registered User
    Join Date
    Jun 2003
    Posts
    6

    Its the file size

    Im pretty certain its the size of the file that causes the bug. I have changed all my game sound files to larger files and I no longer get the problem.

    Im not sure what the exact minimum size of WAV file to get round this bug is. Files larger than 3000K always seem to work, files less than 2500K dont work.

    Does anyone know if the 3650 has this problem as well, or is it just the 7650?

    Tim

  4. #4
    Registered User
    Join Date
    Jun 2003
    Posts
    33

    So do I

    I have to insert silence into wav file to increase its size.

    S60 MIDP SDK seems has many weird bugs. Maybe C++ is a better choice.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×