I have a problem with scrollable areas, it seems like it only the "highest" scrollable area is actually scrollable (highest means that it was first declared in html). But only if it was already shown...

I created an example app for you to test this behavior:
http://dev-wam.browser.ovi.com/wam/v...type=webapp1_0
or short: http://eve-c.org/ex

The first page always works as expected. But when changing the page, only earlier declared pages work....

Page-Structure:
Code:
		<div id="page1" class="sectionizer hide">
	        <div class="ui-header"><div class="ui-title inline"><h1>Page 1</h1></div><div class="refresh-icon inline"><a onclick="refreshPageContent();"><img alt="icon" src="s40-theme/images/refresh_40x40.png"/></a></div></div>
	        <div class="content">
	        	<button class="ui-button" style="width: 200px; margin: 10px 20px;" onclick="mwl.setGroupTarget('#pages', '#page2', 'show', 'hide');">Jump To 2</button>
	        	<button class="ui-button" style="width: 200px; margin: 10px 20px;" onclick="mwl.setGroupTarget('#pages', '#page3', 'show', 'hide');">Jump To 3</button>
	 			<p> A LOT OF TEXT</p>
			</div>
			<div class="footer"><h2>FOOTER CONTENT</h2></div>
		</div>
CSS:
Code:
@charset "utf-8";

.content {
	height: 300px;
	overflow: scroll;
}

.footer {
	height: 60px;
	background-color: grey;
}

.ui-header {
	height: 40px;
	overflow: hidden;
	background-image: url(../images/title-bar.png);
	background-repeat: repeat-x;
	background-position: left top;
}
Full code and css is available in the linked app.

No, it has nothing to do with the sectionizer Class, this one is jsut for you if you open the webapp in a normal browser.

Any know how to fix this? Is it a bug or am I have some crazy CSS error?
I'm not able to fix this... tried it for ~4h, enough.

Byebye,

Ludger