×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Aug 2009
    Posts
    15

    Exclamation Qml BatteryInfo.currentFlow() Problem

    Hello, I have a strange problem, When I run my program for the first time I get a result from BatteryInfo.currentFlow(), but if I close it and run it again, I don't get a result and when I runs it for a third time I get a result, and so on...

    (I test my program on Nokia 500, Nokia 700 and I get same problem)

  2. #2
    Regular Contributor
    Join Date
    Apr 2012
    Location
    malaysia
    Posts
    262

    Re: Qml BatteryInfo.currentFlow() Problem

    Maybe it need to be refresh each time a reading is read.You can put a timer to refresh then start the reading again.

  3. #3
    Registered User
    Join Date
    Aug 2009
    Posts
    15

    Re: Qml BatteryInfo.currentFlow() Problem

    Quote Originally Posted by babylongreece View Post
    Maybe it need to be refresh each time a reading is read.You can put a timer to refresh then start the reading again.
    Thank you.

    I used monitorCurrentFlowChanges, onCurrentFlowChanged and this cause the problem. if I use a Timer and set the interval: 1000 and repeat: true, that make the program lag some time !!!

Similar Threads

  1. E32USER CBASE 46 while getting BatteryInfo
    By bholowasia in forum Symbian
    Replies: 6
    Last Post: 2008-06-13, 16:40

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×