×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Aug 2012
    Posts
    17

    Does the Symbian VOIP keep-alive timer actually work?

    I can make outgoing calls OK (using DID-Logic and the Nokia VOIP function) but incoming calls stop working after a few minutes.

    It has been suggested the SIP Session Interval setting should be changed from 1800 to 0 but this value seems to do nothing. I tried 0, 60, 300, 600, 3600. None of them have any effect.

    SIP is supposed to have a keep-alive timer but it doesn't seem to be functional. This has two issues: the SIP provider may drop the session, and definitely the WIFI router's NAT will close the mapping so the incoming call won't get through.

    There is stuff all over the net (google) and I suspect this is a bug in Nokia's VOIP. The keep-alive feature doesn't do anything.

    There is another setting called Registration, with options of

    When Needed
    Always ON

    which also doesn't do anything whatsoever. If I set Always ON, and come back after a while, I find it has changed back to When Needed. But even if I leave the phone in that menu, and keep it on Always On, the incoming calls still cannot get through after the first few minutes starting from the initial (manual) login to the SIP provider.

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169

    Re: Does the Symbian VOIP keep-alive timer actually work?

    please do make your queries under the selected technology section, I think I already mentioned few times, so what kind of problem you are facing on finding suitable sections ?

  3. #3
    Registered User
    Join Date
    Aug 2012
    Posts
    17

    Re: Does the Symbian VOIP keep-alive timer actually work?

    Apologies - I could not find a section dealing with VOIP.

    I did some debug on the router (Draytek 2955), looking at NAT Sessions. I see the phone opening two ports, 5060 and 49152. Exactly 180 seconds after the last VOIP activity, both disappear. I reckon this has to be the router closing them, so whatever keep-alive timer is required has to do it more frequently than every 180 secs.

    In fact I see this a big general issue because every NAT router will be doing something similar, so a keep alive timer needs to be quite short for incoming calls to work on anybody's WIFI router. Unless one opens those two ports and maps them to the phone's fixed IP, which isn't going to happen if you are on some public network Smiley

    Port 5060 gets opened when the phone logs into the SIP provider.

    Port 49152 gets opened when an incoming call happens.

    Both are connected to 178.63.143.236 which is the VOIP provider.

    So, I tried opening both ports in the router, temporarily.

    AND THAT WORKS. With the phone's NAT session closed by the NAT timeout, the incoming call gets in fine!

    This indicates two things:

    1) There is NO keep-alive process in the phone.

    2) Debugging this should not be hard; all one has to do is watch the NAT table for port 5060 or 49152.

    By trying out various combinations I found that just opening port 5060 for UDP allows incoming calls to work. It looks like 5060 is the VOIP "signalling" port. Haven't tried this for the whole day though! There might be some other session timeout.

    Maybe somebody here might like to report this to Nokia developers.
    Last edited by peter-h; 2013-03-21 at 21:58.

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169

    Re: Does the Symbian VOIP keep-alive timer actually work?

    Basically, would the Symbian C++ be the actual development technology ? for that we do have a section for.

  5. #5
    Registered User
    Join Date
    Aug 2012
    Posts
    17

    Re: Does the Symbian VOIP keep-alive timer actually work?

    OK; I hope that somebody from Nokia (Accenture, these days, I guess) reads this and can perhaps pass it back to development.

    There is a partial solution which is to assign a fixed IP to the phone's WIFI and open up port 5060 in the router's NAT. 5060 is used for VOIP signalling. That gets around the router closing the NAT channel after (in my case) 3 minutes, and I have tested it and it works, but it is not a complete solution because the SIP provider will still eventually kill the VOIP login after (in my case) about half an hour. And it is no good once out of one's house, obviously, so it is completely useless.

    I will continue to investigate but basically it looks like those Belle VOIP features are there, are configurable, but don't do anything. I can watch the NAT sessions on the router in real time and for sure there is no keep-alive process in the phone (808, Belle, FP2, v1507, UK product code).

  6. #6
    Registered User
    Join Date
    Aug 2012
    Posts
    17

    Re: Does the Symbian VOIP keep-alive timer actually work?

    There appears to be little activity on this forum (since about 2010) but in case somebody finds this in a google search, the following may be useful:

    After a massive amount of hassle and experimenting I have finally managed to get my Nokia 808 v1507 FP2 to work on VOIP, both out and incoming.

    With DIDlogic SIP, it is 100% reliable for outgoing calls but only about 50% reliable for incoming calls either due to the 808 session keep-alive failing or due to DIDlogic operating some dodgy timers.

    The SIP service I am using is DIDlogic. They are very cheap but offer very limited support.

    I won't give all the details here (most are at defaults) but in essence I did:

    Default VOIP service - usual stuff /defaults

    AWCDMA=ON (there is a bug in Nokia VOIP which requires this ON even for WIFI)

    SIP session interval 600; later I went to 3600 (the max permitted)


    Under SIP profile

    IETF

    Def destination=Internet

    Registration=when needed (the Always On option is useless as it always returns to When Needed after some time - one of many Nokia bugs)

    Proxy server = all blank

    Reg server:

    Transport=automatic
    Port=5060

    NOW FOR THE CRUCIAL BITS WHICH ARE NOT DOCUMENTED ANYWHERE ESPECIALLY BY NOKIA but which are vital if you want incoming calls to work for more than a few minutes after starting the SIP session:

    NAT Firewall settings:

    Under Domain Parameters

    STUN Settings:

    STUN server 0.0.0.0 and EVERYTHING else for STUN is left blank

    TCP NAT bind refresh timer =55 secs
    UDP NAT bind refresh timer=55 secs

    (my NAT router drops NAT sessions after 180 secs and some routers might be 60 so I chose 55)

    CRLF refresh=ON
    Used NAT protocol=blank

    IAP parameters:

    There should not be anything in there, since if you add any network connections there, you get default values which don't really work:

    TCP NAT bind refresh timer =1200
    UDP NAT bind refresh timer=28
    STUN retransmission=250 (value is in milliseconds)

    It now works for in and out calls, over wifi and 3G. I have the 729 codec at the top of the list; not that it seems to make much difference. 3G gives poor quality, HSPA or WIFI is very good.

    Configuring the NAT firewall values above causes the phone to send out packets to stop the WIFI router from closing the NAT path. However this alone did not work on 3G networks.

    Configuring the 0.0.0.0 for the STUN server was the crucial bit, which not only maintains the SIP session with DIDlogic but also keeps up the connection over 3G. Without this incoming calls stop working after a few minutes. I am generally able to receive incoming calls for something like 1-2 hours after starting the SIP session.

    I hope this is useful to somebody, as the net is full of people (often with Nokia phones) tearing their hair out.

    DIDlogic seem to work on a finite support policy i.e. after X emails they cut off comms, but STUN server stuff (especially the bizzare 0.0.0.0 workaround) doesn't appear to be documented on their website.

    Incidentally I tried to change the NAT firewall settings

    TCP NAT bind refresh timer =55 secs
    UDP NAT bind refresh timer=55 secs

    with

    TCP NAT bind refresh timer =1200 secs
    UDP NAT bind refresh timer=28 secs

    to match the ones under STUN but that does NOT work. The NAT router seems to need a TCP NAT refresh which is shorter than its NAT timeout which in my case (Draytek 2955) is 180 secs. UDP refresh alone doesn't seem to keep the NAT session active.

    And finally: reboot the phone after doing any changes to the settings Some of them work straight off, others don't.

    Basically I think the Nokia VOIP app keep-alive process is either crippled (and this was never fixed because very few people will be using a phone for incoming VOIP calls) or it can be made to work with a very weird combination of settings which are not documented. I did a massive amount of googling to get this far.

Similar Threads

  1. my timer just work once
    By koraykayir in forum Symbian
    Replies: 1
    Last Post: 2010-11-03, 09:27
  2. Voip cant get SIP to work...HELP
    By slicemaster101 in forum VoIP
    Replies: 6
    Last Post: 2008-12-24, 14:34
  3. My E61 voip can not work
    By xiaodke in forum VoIP
    Replies: 0
    Last Post: 2006-12-26, 11:10
  4. HTTP Keep-Alive (again) - should it work this way?
    By Marat Khalili in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2005-05-16, 07:32
  5. Timer.scheduleAtFixedRate doesn't seem to work correctly
    By doctordwarf in forum Mobile Java General
    Replies: 2
    Last Post: 2003-10-21, 08:27

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×