×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Registered User
    Join Date
    Apr 2013
    Posts
    5

    Lumia 920 Deployment issue

    I use Nokia Lumia 920 for developing apps. All is working OK, but once when I've tried to debug app I had next error: "Application could not be launched for debugging. Ensure the target device screen is unlocked and that the application is installed." I've checked and found that app is installed and screen is unlocked. I tried to reboot pc and phone, but this issue appeared again. Then I reset my phone. After reset application work normally. But later this issue occured again.

  2. #2
    Nokia Developer Champion
    Join Date
    Sep 2012
    Location
    Morocco
    Posts
    297

    Re: Lumia 920 Deployment issue

    Quote Originally Posted by Orinichev View Post
    I use Nokia Lumia 920 for developing apps. All is working OK, but once when I've tried to debug app I had next error: "Application could not be launched for debugging. Ensure the target device screen is unlocked and that the application is installed." I've checked and found that app is installed and screen is unlocked. I tried to reboot pc and phone, but this issue appeared again. Then I reset my phone. After reset application work normally. But later this issue occured again.
    Do you have the lastest 920 update ?
    What kind of feature are you testing with your app ? (camera ? nfc ? ...)
    Does that happens after app crashes ?

  3. #3
    Registered User
    Join Date
    Apr 2013
    Posts
    5

    Re: Lumia 920 Deployment issue

    I've updated phone. But now I am having error
    Deployment optimization failed with error: '0x80070005'. If the problem continues uninstall the app, restart your Windows Phone and retry.

  4. #4
    Nokia Developer Champion
    Join Date
    Feb 2013
    Location
    Dublin, Ireland
    Posts
    564

    Re: Lumia 920 Deployment issue

    If you open Visual Studio 2012 and create a new blank Windows Phone 8 project, does that deploy to the phone?

  5. #5
    Registered User
    Join Date
    Apr 2013
    Posts
    5

    Re: Lumia 920 Deployment issue

    Yes. Moreover, if I change Product ID of application which has issue, it works! But this solution is not suite for me.

  6. #6
    Nokia Developer Champion
    Join Date
    Feb 2013
    Location
    Dublin, Ireland
    Posts
    564

    Re: Lumia 920 Deployment issue

    Do you have another device you can try to deploy the app to?

  7. #7
    Registered User
    Join Date
    Apr 2013
    Posts
    5

    Re: Lumia 920 Deployment issue

    Yes. And it work in other device

  8. #8
    Nokia Developer Champion
    Join Date
    Feb 2013
    Location
    Dublin, Ireland
    Posts
    564

    Re: Lumia 920 Deployment issue

    Although you mentioned that you updated your Lumia 920, have you reset it?

    Also, have you removed all previous versions of the app from the phone?

  9. #9
    Nokia Developer Champion
    Join Date
    Sep 2012
    Location
    Morocco
    Posts
    297

    Re: Lumia 920 Deployment issue

    as the error and theothernt stated just : "uninstall the app, restart your Windows Phone and retry"
    while restarting your phone, leave it off for about 10 sec. then switch on and try again.

  10. #10
    Nokia Developer Moderator
    Join Date
    Feb 2011
    Location
    Portugal
    Posts
    957

    Re: Lumia 920 Deployment issue

    That is really strange. Have you tried to clean up the temp files? You can do that now with the new app Storage Check with the new update. There is an option to clean the temp files there. See if that works.

  11. #11
    Registered User
    Join Date
    Apr 2013
    Posts
    5

    Re: Lumia 920 Deployment issue

    Thank you. Problem solved but not by using Storage Check application. During holidays mobile spent whole battery and switch off. Today I've charged device and application installs normally. I think some debug information was hold i9n memory and prevent debugger work.

  12. #12
    Nokia Developer Moderator
    Join Date
    Feb 2011
    Location
    Portugal
    Posts
    957

    Re: Lumia 920 Deployment issue

    Quote Originally Posted by Orinichev View Post
    Thank you. Problem solved but not by using Storage Check application. During holidays mobile spent whole battery and switch off. Today I've charged device and application installs normally. I think some debug information was hold i9n memory and prevent debugger work.
    Can you give us a bit more context? Was it a C++ or C#/VB app? Also if it happens again, please do let us know and provide some more details if possible.

Similar Threads

  1. Issue with WP7 NavigationService.Navigate on Lumia 900
    By IEatBugsForBreakfast in forum Windows Phone General
    Replies: 3
    Last Post: 2012-12-09, 21:13
  2. My Lumia 800 developer device screen issue
    By pigling in forum Windows Phone General
    Replies: 4
    Last Post: 2012-09-16, 12:15
  3. wifi issue with lumia 800
    By hclchd in forum General Development Questions
    Replies: 5
    Last Post: 2012-02-14, 10:21
  4. Midlet Deployment Issue .......
    By afezuh_z in forum Mobile Java General
    Replies: 14
    Last Post: 2008-01-31, 13:11
  5. JAD deployment issue - installs OK, but then what?
    By jat in forum Mobile Java General
    Replies: 1
    Last Post: 2006-11-06, 17:24

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×