×

Discussion Board

Results 1 to 7 of 7

Hybrid View

  1. #1
    Registered User
    Join Date
    Apr 2012
    Posts
    17

    Enabling t9 support in qwebview

    Hello, I’m testing qtwebkit on symbian and I am really frustrated about that predictive text isn’t supported by default. How can I resolve this problem, thank you very much.

  2. #2
    Registered User
    Join Date
    Apr 2012
    Location
    malaysia
    Posts
    260

    Re: Enabling t9 support in qwebview

    Did you use Nokia 808 as a test device ?.If yes i think you need to enable it first in phone setting.

  3. #3
    Registered User
    Join Date
    Apr 2012
    Posts
    17

    Re: Enabling t9 support in qwebview

    Quote Originally Posted by babylongreece View Post
    Did you use Nokia 808 as a test device ?.If yes i think you need to enable it first in phone setting.
    Yes, predictive text is enabled from settings but can't be used in the app.
    Last edited by daljit97; 2013-05-08 at 18:26.

  4. #4
    Registered User
    Join Date
    Apr 2012
    Location
    malaysia
    Posts
    260

    Re: Enabling t9 support in qwebview

    Quote Originally Posted by daljit97 View Post
    Yes, predictive text is enabled from settings but can't be used in the app.
    Did you mean the predictive didn't work as it should be before or the alphanumeric keypad won't show up.You need to elaborate more.

  5. #5
    Registered User
    Join Date
    Apr 2012
    Posts
    17

    Re: Enabling t9 support in qwebview

    Actually the alphanumeric keyboard show up but without predictive text support.

  6. #6
    Registered User
    Join Date
    Apr 2012
    Location
    malaysia
    Posts
    260

    Re: Enabling t9 support in qwebview

    There seems to be a problem with predictive text as discussed on this thread.Could be the issue you facing is the same as the users mention there.

  7. #7
    Registered User
    Join Date
    Apr 2012
    Posts
    17

    Re: Enabling t9 support in qwebview

    Quote Originally Posted by babylongreece View Post
    There seems to be a problem with predictive text as discussed on this thread.Could be the issue you facing is the same as the users mention there.
    No, that is not the problem. The problem is actually that QtWebkit automatically disables preditive text using this role: Qt::ImhNoPredictiveText. the solution should find a way to enable it.

Similar Threads

  1. Enabling SIP profile
    By meandnano in forum VoIP
    Replies: 0
    Last Post: 2011-03-01, 08:25
  2. Replies: 3
    Last Post: 2010-09-09, 19:56
  3. Enabling IP forwarding
    By tsdgeos in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2009-04-03, 15:02
  4. Enabling/Disabling red key - How ?
    By soontobeared in forum Symbian
    Replies: 6
    Last Post: 2009-03-10, 19:43
  5. RAS Enabling
    By sakhya in forum Symbian
    Replies: 1
    Last Post: 2004-10-30, 18:27

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •