Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Aug 2008
    Posts
    8

    Extension plugin (partner API) certificate expired

    I have one application that utilize the Call Audio Control API from the SDK API Plugin for S60 3rd FP2 (see http://www.developer.nokia.com/Commu...DK_API_Plug-in).

    This means that a SISX file containing the API is included in the SISX file for the application - and the API is installed as the application is installed.

    The SISX file with the API is signed by Nokia - and the problem is that the certificate has now expired (expired April 18 this year).
    This means that the application no longer can be installed (without adjusting the time on the device).

    Below is the output from SignSIS tool for the Call Audio Control SISX:

    >>>signsis -o callAudioControl_32_0x10207bd2.SISX

    Primary:
    Issued by Nokia Online CA.
    Issued to Nokia.
    Valid from 18/04/2008 to 18/04/2013.
    Issued by Nokia Content Signing CA.
    Issued to Nokia.
    Valid from 22/10/2007 to 20/10/2012.


    Question is how this can be fixed.
    Do Nokia need to provide a version that is signed with a newer certificate (if so - when can this happen)? Is this still supported?
    Or can this be fixed in some other way - can i sign it myself in some way?

    Any ideas anyone?

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Extension plugin (partner API) certificate expired

    Hi rolm,

    the S60 5th Edition plug-in package (https://www.developer.nokia.com/info...60_3rd_ed.html) has the CAC sis files (v1.2.1) with signature valid until 04.2014. You can download the package and find the sis files under \plugins\Extensions_sdk\examples\CallAudioControlUiEx\sis
    The installer may warn you if it does not find a S60 5.0 SDK but then it allows you to unpack the content in a temp directory, so you don't have to install the S60 5.0 SDK if you are not using it already.

    That being said, I will add it to my task list to find all these floating bits of SIS files and sign them again in order to extend their validity.

    Best regards,
    Lucian
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Registered User
    Join Date
    Aug 2008
    Posts
    8

    Re: Extension plugin (partner API) certificate expired

    Hi Lucian
    Is there any news about re-signing the Call Audio Control SIS file? Do you know if it will be re-signed before April 2014 or not?
    I ask since we need to plan our work accordingly - in practice, if the SIS expires in April we need to release a new version of our application with some functionality removed. Since this means a few days work and testing it would be great to know as soon as possible if this will be needed or not.

    It would also feel sad to remove stuff that works simply due to an expired certificate.

    Br
    // Roland

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Extension plugin (partner API) certificate expired

    Hi Roland,

    thanks for reminding me about this task. I was trying to get CAC (and similar packages) signed through Symbian Signed as that would give them a longer validity period (matching that of the apps using the libs). Unfortunately that is still not possible so for now I submitted the CAC packages to Nokia signing, which will extend the signature only until January 2016.
    I should have them back in a couple of days and I will publish that version at http://developer.nokia.com/Community...les_repository

    I will update them later if I manage to extend the validity beyond that date, so you should subscribe to receive notifications from that wiki page.

    Also, if there are other Nokia SIS files in use which would have to be re-signed, please add a note to that wiki page as well.

    Best regards,
    Lucian
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  5. #5
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Extension plugin (partner API) certificate expired

    The Call Audio Control libraries are now available at http://developer.nokia.com/Community...les_repository with updated signatures.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. RDA certificate expired
    By jkosonen in forum Feedback - Developer Services & Infrastructure
    Replies: 5
    Last Post: 2012-04-12, 08:39
  2. Why expired certificate?
    By mertama in forum General Development Questions
    Replies: 1
    Last Post: 2010-04-15, 15:26
  3. Partner Plugin Pack for 5th edition
    By Paul.Todd in forum Symbian User Interface
    Replies: 3
    Last Post: 2009-02-06, 10:49
  4. Certificate for MWS expired
    By maggias in forum Mobile Web Server
    Replies: 3
    Last Post: 2008-06-04, 08:44
  5. expired certificate on carbide.vs sample developer certificate
    By ya_la in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 1
    Last Post: 2006-11-06, 06:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×