×

Discussion Board

Results 1 to 14 of 14
  1. #1
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,227

    Cool I need s60 3rd edition SDK whose version of OS is v9.4 or higher. Iam getting error

    s603rdSDK's.jpgs603rd.jpg


    Why this error is showing I have following SDK's already with me whose version is v9.3


    S60_3rd_FP2_SDK_v1.1

    S60_3rd_FP2_SDK_v1.1_2

    S60_3rd_MR

    S60_3rd_FP1

    S60_3rd_FP2_Beta.



    Please help me Iam using
    Carbide.c++ Version 3.2.0
    Build v201103180854_33

    for building and packaging or running the symbian applications.
    Last edited by GTO_India; 2013-07-08 at 08:46.

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,689

    Re: I need s60 3rd edition SDK whose version of OS is v9.4 or higher. Iam getting er

    It is normal. Check the release notes for Carbide.c++ or just read the last few lines from https://www.developer.nokia.com/Reso...r/Carbide.c++/ ("With which Symbian platforms and devices is Carbide.c++ compatible?")

  3. #3
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,227

    Re: I need s60 3rd edition SDK whose version of OS is v9.4 or higher. Iam getting er

    ok then can two versions or types of carbide c++ installed at a time on my pc

  4. #4
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,538

    Re: I need s60 3rd edition SDK whose version of OS is v9.4 or higher. Iam getting er

    Quote Originally Posted by GTO_India View Post
    ok then can two versions or types of carbide c++ installed at a time on my pc
    Yes you can.

  5. #5
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,689

    Re: I need s60 3rd edition SDK whose version of OS is v9.4 or higher. Iam getting er

    Yes, you can.

  6. #6
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,227

    Re: I need s60 3rd edition SDK whose version of OS is v9.4 or higher. Iam getting er

    Thank You very much wizard

  7. #7
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,227

    Re: I need s60 3rd edition SDK whose version of OS is v9.4 or higher. Iam getting er

    But How I have built S60 3rd edition fp2 beta and fp2 ,MR App with carbide c++ v 3.2 only . can u please clarify.


    Now Iam seeing the following in carbide c++ v2.7


    screenshots.jpg
    Last edited by GTO_India; 2013-07-08 at 13:11.

  8. #8
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,689

    Re: I need s60 3rd edition SDK whose version of OS is v9.4 or higher. Iam getting er

    While the two variants of Carbide.c++ can be installed together, they need two separate workspace folders as the project configuration files they use are going to be different.
    So make sure that Carbide.c++ v2.7 has its own workspace folder (the default is probably c:\symbian\carbide, which is already used by Carbide.c++ v3.2), and import the project(s) there. While importing you will have the opportunity to select the S60 3rd edition SDK-s you want to use.
    Switch workspace item resides in the File menu.
    If you already have a separate workspace, you should check if Carbide.c++ v2.7 sees the SDK-s, they are configured somewhere in Window/Preferences/Carbide.c++/something about SDK-s. There is a button for automatic detection as I remember, or you can just add the SDK-s manually (in this case it will ask you to show the folder where the SDK is, and recognize it automatically afterwards).
    Also, since you want to use all kinds of S60 3rd edition SDK-s, when you select the platforms and toolchains, go for SBSv1 when asked (SBSv1 is the "traditional" bldmake+abld build system, SBSv2 is the new one with sbs.bat. As all S60 3rd edition variants support the old toolchain, but S60 3rd MR can not work with the new one, it is more straightforward to pick SBSv1 for everything 3rd edition).

  9. #9
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,227

    Re: I need s60 3rd edition SDK whose version of OS is v9.4 or higher. Iam getting er

    Hi wizard it would be helpful for me if u handle my Pc with teamviewer and explain the changes needed.


    Please can I know ur contact detials etc. will u be online on any skype etc.

    You r right I chosedn the same workspace .

    I will correct it now

  10. #10
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,227

    Re: I need s60 3rd edition SDK whose version of OS is v9.4 or higher. Iam getting er

    Error when changed the workspace tried to rebuild


    my new workspace is C://carbideworkspace



    LDMAKE ERROR: Directory "\Symbian\9.2\S60_3rd_FP1_2\EPOC32\" does not exist

    === BLDMAKE Command failed with error code 1 ===
    ***Stopping. Check the Problems view or Console output for errors.

    ***Errors were detected in build. See the Problems or Console view for details.

    Total Time: 20 sec

  11. #11
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,538

    Re: I need s60 3rd edition SDK whose version of OS is v9.4 or higher. Iam getting er

    Could it be possible to adhere to suggestions in your other thread of a week old with the similar error? http://www.developer.nokia.com/Commu...ot-does-not-ex

  12. #12
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,227

    Re: I need s60 3rd edition SDK whose version of OS is v9.4 or higher. Iam getting er

    Yes Neil First I have deleted the project from workspace and then imported it again from the orginal path i.e in My computer F drive.


    still the error is showing


    Creation Time Description Resource Path Location Type
    1373351300833 BLDMAKE ERROR: Directory "\Symbian\9.2\S60_3rd_FP1_2\EPOC32\" does not exist MyView_MySearch Unknown C/C++ Problem


    But epoc32 is existing at \Symbian\9.2\S60_3rd_FP1_2\


    can u help me with teamviewer tec.

  13. #13
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,227

    Re: I need s60 3rd edition SDK whose version of OS is v9.4 or higher. Iam getting er

    Nel and wizard Yes you right If I import the project from the other workspace itself no error showing like " epoc32 does not exists "

  14. #14
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,538

    Re: I need s60 3rd edition SDK whose version of OS is v9.4 or higher. Iam getting er

    Quote Originally Posted by GTO_India View Post
    my new workspace is C://carbideworkspace
    Quote Originally Posted by GTO_India View Post
    My computer F drive.
    Like many times over in the past threads of yours, you missed one of the points mentioned to you (In the other thread which is a week old and also in your threads couple of years old ), you are heading for a pitfall with these different drives. Remember the SDK and the workspace need to be on the same drive.

Similar Threads

  1. How to get SDK version in S60 3rd Edition.
    By Kathy_zhenzhen in forum Symbian
    Replies: 2
    Last Post: 2009-07-30, 06:49
  2. Replies: 3
    Last Post: 2006-09-19, 03:51
  3. Replies: 1
    Last Post: 2005-01-01, 15:44
  4. Symbian programs - Unable to run with higher version of JAVA
    By ja_calulot in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2004-01-29, 15:38
  5. Replies: 0
    Last Post: 2003-11-27, 02:43

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×