×

Discussion Board

Page 3 of 4 FirstFirst 1234 LastLast
Results 31 to 45 of 53
  1. #31
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,265

    Re: Image and name as expected not showing when a Symbian app is rebuilt, Updated ag

    Yes Neil Yeserday I have built a sample aplication and my given my icon and it is working fine for Nokia symbian 3 SDK .

    I will just check a helloworld app for s60 3rd fp1_2 too
    Last edited by GTO_India; 2013-07-19 at 09:17.

  2. #32
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,265

    Re: Image and name as expected not showing when a Symbian app is rebuilt, Updated ag

    My mif file i.e "MyView_0x2004aa1e.mif " is not getting created at data\z\resource\apps after running or building the App Why is it so?

    Where as mifconv tool Iam able to create it at Epoc32\tools and hence I have changed in the .pkg file as


    "$(EPOCROOT)Epoc32\tools\MyView_0x2004aa1e.mif" -"!:\resource\apps\MyView_0x2004aa1e.mif"

  3. #33
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: Image and name as expected not showing when a Symbian app is rebuilt, Updated ag

    Post your _reg.rss file here.
    Post the LOCALISABLE_APP_INFO block here from the main .rss file.
    The .mif file is created in tools because you are running mifconv manually, there. It is probably not a problem, your .mif file is deployed correctly.

  4. #34
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,265

    Re: Image and name as expected not showing when a Symbian app is rebuilt, Updated ag

    Hi wizard



    my _reg.rss


    #include "MyView.rls"
    #include <appinfo.rh>
    #include <MyView_0x2004aa1e.rsg>

    UID2 KUidAppRegistrationResourceFile
    UID3 0x2004aa1e

    RESOURCE APP_REGISTRATION_INFO
    {
    app_file="MyView_0x2004aa1e";
    localisable_resource_file = STRING_myview_loc_resource_file_1;
    localisable_resource_id = R_LOCALISABLE_APP_INFO;


    embeddability=KAppNotEmbeddable;
    newfile=KAppDoesNotSupportNewFile;
    }


    in main.rss



    RESOURCE LOCALISABLE_APP_INFO r_localisable_app_info
    {
    short_caption = qtn_app_short_caption_string;
    caption_and_icon =
    CAPTION_AND_ICON_INFO
    {
    caption = qtn_app_caption_string;

    number_of_icons = 1;
    icon_file = "\\resource\\apps\\MyView_0x2004aa1e.mif";
    };
    }



    block here from the main .rss file ?
    Last edited by GTO_India; 2013-07-24 at 09:10.

  5. #35
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,265

    Re: Image and name as expected not showing when a Symbian app is rebuilt, Updated ag

    why .mif is not created at ""$(EPOCROOT)epoc32\data\z\resource\apps\" then ?

  6. #36
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,265

    Re: Image and name as expected not showing when a Symbian app is rebuilt, Updated ag

    Hi wizard_ hu Iam waiting for the reply from you

  7. #37
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: Image and name as expected not showing when a Symbian app is rebuilt, Updated ag

    In theory it looks fine. A thing you may want to check is copying the .mif and the original .svg file somewhere on the mass storage drive, and try opening them with the built-in file browser.

  8. #38
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: Image and name as expected not showing when a Symbian app is rebuilt, Updated ag

    Quote Originally Posted by GTO_India View Post
    why .mif is not created at ""$(EPOCROOT)epoc32\data\z\resource\apps\" then ?
    mifconv creates the icons file where you say it to create. If not path information is specified, it creates the .mif into the current folder.
    If you check the icon_aif.mk and similar files of the example applications, you will see that it is explicitly written there that the icon file should go to $(EPOCROOT)epoc32\data\z\resource\apps\, these things do not happen automatically.

  9. #39
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,265

    Re: Image and name as expected not showing when a Symbian app is rebuilt, Updated ag

    buit-in file browser? Any way i will see
    Last edited by GTO_India; 2013-07-26 at 13:13.

  10. #40
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,563

    Re: Image and name as expected not showing when a Symbian app is rebuilt, Updated ag

    Quote Originally Posted by GTO_India View Post
    buit-in file browser?
    Yes, there is a builtin file browser, check your phone for details!! You also have options of browsing using the 3rd party file browsers too. Jukka has one whichh has been popular for ages now.

  11. #41
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,265

    Re: Image and name as expected not showing when a Symbian app is rebuilt, Updated ag

    Hi Neil and Wizard Now after changing my workspace three thinga are getting created when I run or Build the application.

    Those are


    MyView_0x2004aa1d.mif of my App Icon

    MYView_newImage.mif of my App screenshot

    MYView_newImage.mbm of my App screenshot



    Even though all are crated at C:\Nokia\devices\Nokia_Symbian3_SDK_v1.0\epoc32\data\z\resource\apps


    My App Icon is not showing I doubt whether t is due to my sbs problem

    I have also asked the query related to sbs (The Symbian Build System (sbs) cannot be found on the PATH. Carbide needs a valid SBS installation on the PATH to use the SBSv2 builder i.e Raptor/SBSv2 minimum version supported in carbide c++ is 2.15.0 .Your sbs version is 0.0.0.Please update your sbs installation and ReScan from the Build Configuration Filtering Prference page..)

    at

    http://developer.nokia.com/Community...376#post924376

  12. #42
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,563

    Re: Image and name as expected not showing when a Symbian app is rebuilt, Updated ag

    Quote Originally Posted by GTO_India View Post
    Even though all are crated at C:\Nokia\devices\Nokia_Symbian3_SDK_v1.0\epoc32\data\z\resource\apps


    My App Icon is not showing
    Thats probably because you may not be thinking of changing back the paths in the pkg file.

    Quote Originally Posted by GTO_India View Post
    I doubt whether t is due to my sbs problem
    Can you kindly explain what logical conclusion makes you think this, especially whe you claim that the app icons are created where its supposed to be.

    Hi Neil and Wizard
    You would get many people to help you if you dont call out to specific persons help
    Last edited by Symbian_Neil; 2013-08-19 at 10:51. Reason: typo

  13. #43
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,265

    Re: Image and name as expected not showing when a Symbian app is rebuilt, Updated ag

    what do you mean by


    changing back the paths in the pkg file ?

    Ok can someone kindly answer the query related to sbs also

    My .pkg files look like this

    ; Seven files to install
    ;
    "$(EPOCROOT)\Epoc32\release\$(PLATFORM)\$(TARGET)\MyView_0x2004aa1d.exe" -"!:\sys\bin\MyView_0x2004aa1d.exe"

    "$(EPOCROOT)\epoc32\data\Z\resource\apps\MyView_0x2004aa1d.rsc" -"!:\resource\apps\MyView_0x2004aa1d.rsc"

    "$(EPOCROOT)\epoc32\data\z\resource\apps\MyView_0x2004aa1d.mif" -"!:\resource\apps\MyView_0x2004aa1d.mif"

    "$(EPOCROOT)\epoc32\data\Z\private\10003a3f\apps\MyView_reg.rsc" -"!:\private\10003a3f\import\apps\MyView_reg.rsc"

    "$(EPOCROOT)epoc32\data\z\resource\apps\MyView_mbm.mbm" -"!:\resource\apps\MyView_mbm.mbm"

    "$(EPOCROOT)Epoc32\data\z\resource\apps\MYView_newImage.mif" -"!:\resource\apps\MYView_newImage.mif"

    "$(EPOCROOT)Epoc32\data\z\resource\apps\MYView_newImage.mbm" -"!:\resource\apps\MYView_newImage.mbm"
    Last edited by GTO_India; 2013-08-19 at 13:41.

  14. #44
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,563

    Re: Image and name as expected not showing when a Symbian app is rebuilt, Updated ag

    Did you restart your device?

    Well actually there are a number of suggestions already in this same thread itself (and a few of your other older threads on the same issue), instead of repeating, can you try all the suggestions in the previous posts of the thread where in post #31 you say that it worked.

  15. #45
    Super Contributor
    Join Date
    Nov 2010
    Posts
    1,265

    Re: Image and name as expected not showing when a Symbian app is rebuilt, Updated ag

    Yes I have restarted the device twice.

Similar Threads

  1. image not showing !
    By Thirdage in forum Qt
    Replies: 2
    Last Post: 2013-04-13, 12:52
  2. Delays to be expected: Symbian Signed and Nokia Services heavily short-handed
    By aaumala in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 0
    Last Post: 2011-04-12, 13:39
  3. Bmp image not showing
    By anindyasen.cse in forum Symbian User Interface
    Replies: 4
    Last Post: 2009-03-07, 06:26
  4. Image not being updated Problem
    By coolblues5000 in forum Symbian Media (Closed)
    Replies: 4
    Last Post: 2008-11-10, 02:54

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×