×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Feb 2013
    Location
    Madrid
    Posts
    84

    Container style, from code or from Resources....not working fine

    I'm building a Container using code and now I want to set the Styleusing one UnselectedStyle from the Resource Editor.

    I'm doing this because, I don't find the way to add a LinearBackground color and a RoundBorder to my Container. When I put the two properties to the Style, the background color has gone.

    So I finally add this Style using the UIManager.getInstance().addThemeProps(String name ThemeFromResource); and later the setUIID(String nameStyle). Is working fine...my Containergets the Style, but the app lose the navigation, the back Commandhas gone.

    How can do this? I would like to do with my first way...creating the lineargradient and the border and adding it to the style, but I don't find the way.

  2. #2
    Nokia Developer Champion
    Join Date
    Mar 2013
    Posts
    686

    Re: Container style, from code or from Resources....not working fine

    I didnt exactly understand what you are trying to do but you should know that anything you can do via the Resource editor can be done in code and vice-versa.
    You should look into the API documentation of Style ( i think what you look for is Style.setBackgroundType and setBackgroundGradientStartColor setBackgroundGradientEndColor()

  3. #3
    Registered User
    Join Date
    Feb 2013
    Location
    Madrid
    Posts
    84

    Re: Container style, from code or from Resources....not working fine

    I find the way to solve that. Adding the style to the nokia resources file I can use it without needing to add ThemeProps etc

Similar Threads

  1. MAD Developer not working fine
    By ramkashyap17 in forum Nokia N9
    Replies: 2
    Last Post: 2011-07-15, 08:25
  2. Replies: 3
    Last Post: 2011-02-27, 09:30
  3. WebPost not working on device, working fine on emulator
    By swarupk2007 in forum Symbian Networking & Messaging (Closed)
    Replies: 2
    Last Post: 2010-02-09, 14:59
  4. NSSTTS not working fine
    By shafali gupta in forum Symbian
    Replies: 1
    Last Post: 2009-04-06, 13:37
  5. [defect report] carbide.cpp code formatter can't produce code conforming to s60 style
    By simo.salminen in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2008-10-27, 10:56

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×