×

Discussion Board

Results 1 to 1 of 1
  1. #1
    Registered User
    Join Date
    Apr 2003
    Posts
    6

    Eclipse + Nokia emulator debugging

    Hi all,

    I use Eclipse + Antenna to compile and package my midlet.

    I know that Eclipse have some problems to debug midlet with WTK and Nokia emulators.
    But I found that the emulator from the sdk Series_60_SDK_MIDP_Concept_Beta_0_2 can work with the Eclipse debug front end.
    I launch the emulator in debug as server and I remotely connect with an Eclipse debug session.

    Here the command line steps: I suppose that the nokia sdk it is in the wtklib\devices folder

    I run the emulator in this way:

    c:\wtk104\bin\emulator -classpath midlet.jar -Xdevice:Series_60_MIDP_SDK_Concept_Beta_0_2 -Xdescriptor:midlet.jad -Xdebug -Xrunjdwp:transport=dt_socket,address=8000,server=y

    Inside Eclipse I open a Remote Debugging session on the port 8000, I also specify the location of emulator.jar package in the debug session classpath

    BUT...that ok just for the first time I run the midlet, because the others time the emulator crash saying: "ALERT attempting to resume thread", and to be able to repeat the procedure I need to restart the computer.

    Anyone have the same problem?
    Anyone manage to use any emulator with the Eclipse debug front end?

    Nokia support: any hint?

    Thanks for the attention

    Ludovico Cellentani
    Software Engineer
    Last edited by ludo74; 2003-06-26 at 08:49.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×