×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Nokia Developer Champion
    Join Date
    Sep 2012
    Location
    Morocco
    Posts
    291

    [Strange behavior] IsWiFiEnabled always returns true after published to store

    Hello
    I've got an app that uses DeviceNetworkInformation.IsWiFiEnabled and IsCellularDataEnabled
    When testing the app in debug/release mode, everything is working just fine, but when trying the app after publishing it or putting it in beta store, DeviceNetworkInformation.IsWiFiEnabled and IsCellularDataEnabled always returns true.

    this Happens only for WP8, for WP7 everything is fine.
    Is it a bug related to the os ? if no, is there a way to fix it ?

    Thank you !

  2. #2
    Nokia Developer Champion
    Join Date
    Feb 2013
    Location
    Dublin, Ireland
    Posts
    475

    Re: [Strange behavior] IsWiFiEnabled always returns true after published to store

    Is it a WP7 app running on WP8?

    Also, have tried running the app in Release mode on a WP8 device to replicate the issue, or does the issue only appear in the store version?

  3. #3
    Nokia Developer Champion
    Join Date
    Sep 2012
    Location
    Morocco
    Posts
    291

    Re: [Strange behavior] IsWiFiEnabled always returns true after published to store

    Thank Theo for your answer,
    As I said :
    for WP7 everything works fine, no problem
    for WP8 it works in Debug and release mode, but when published in public or beta store, it doesn't work (i.e. it always returns true) .

  4. #4
    Nokia Developer Champion
    Join Date
    Sep 2012
    Location
    Morocco
    Posts
    291

    Re: [Strange behavior] IsWiFiEnabled always returns true after published to store

    Quote Originally Posted by theothernt View Post
    Out of curiosity, try upgrading the WP7 project to WP8, run it on device and see if the issues persists - it does sound like yet another 'quirks mode' bug though

    The issue first appeared with a project upgraded from WP7 to WP8, then I created another WP8 project see if it could solve it.
    but no, the issue appears in both projects when published
    Last edited by Loukt; 2013-08-15 at 16:38.

  5. #5
    Nokia Developer Champion
    Join Date
    Feb 2013
    Location
    Dublin, Ireland
    Posts
    475

    Re: [Strange behavior] IsWiFiEnabled always returns true after published to store

    Out of curiosity, try upgrading the WP7 project to WP8, run it on device and see if the issues persists - it does sound like yet another 'quirks mode' bug though

  6. #6
    Nokia Developer Champion
    Join Date
    Sep 2012
    Location
    Morocco
    Posts
    291

    Re: [Strange behavior] IsWiFiEnabled always returns true after published to store

    Solved : I had to check : "ID_CAP_NETWORKING"

  7. #7
    Nokia Developer Champion
    Join Date
    Feb 2013
    Location
    Dublin, Ireland
    Posts
    475

    Re: [Strange behavior] IsWiFiEnabled always returns true after published to store

    Quote Originally Posted by Loukt View Post
    Solved : I had to check : "ID_CAP_NETWORKING"
    Good to know - at least the API isn't broken ;-)

Similar Threads

  1. GetNextDataPart() never returns true
    By nmnir in forum Symbian C++
    Replies: 4
    Last Post: 2008-11-12, 02:44
  2. Red Key .. Strange Behavior...
    By netlogins in forum Symbian C++
    Replies: 2
    Last Post: 2007-05-03, 16:13
  3. Strange Behavior
    By akermen in forum Symbian C++
    Replies: 0
    Last Post: 2006-03-15, 00:28
  4. Please help me! Strange behavior...
    By djpirra in forum Mobile Java General
    Replies: 1
    Last Post: 2004-01-17, 11:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •