×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Aug 2013
    Posts
    6

    Asha SDK 1.0 Emulator can't access internet (network)

    Hello,

    I was trying to create my first app for the new Nokia Asha 501 and after viewing some of the examples provided with the SDK, I sort of built something.

    My app is supposed to get information from a website, and, step by step, I created the basis of what is needed to open an url. But, with only this little code, nothing happened.

    Then, just to be sure the problem was not mine, I tried to use the LWUITBrowser to connect to some URL (used the Google link there), and it couldn't connect to the internet (error 65556). Also the phone internet browser couldn't either connect to the internet.

    I tried this in two machine configurations: Windows 7 and Windows XP SP2 (both connected to a wireless network at home) and the problem occurs in both machine configurations.

    Is there something I need to do first to make the emulator able to connect to the internet? Am I forgetting something?


    Thank you.

    Jorge Daniel

  2. #2
    Nokia Developer Champion
    Join Date
    Mar 2003
    Posts
    4,104

    Re: Asha SDK 1.0 Emulator can't access internet (network)

    Nothing to do.
    But remember these are like real devices. If you turned off mobile data in your Nokia Asha 501 Settings, the emulator does not have Internet.

  3. #3
    Registered User
    Join Date
    Aug 2013
    Posts
    6

    Re: Asha SDK 1.0 Emulator can't access internet (network)

    Thank you for bring me that to attention. I reinstalled the SDK and now it works. Maybe I set off mobile data without knowing what I was doing...

  4. #4
    Nokia Developer Champion
    Join Date
    Mar 2003
    Posts
    4,104

    Re: Asha SDK 1.0 Emulator can't access internet (network)

    Furthermore roaming could be an issue. Again, if the phone thinks it is roaming and data roaming is turn off …
    In the just yesterday released Asha Software Platform 1.1 emulator, I had to turn on Wi-Fi in the phone itself to get HTTP working. There might be a bug floating around.

Similar Threads

  1. S40 SDK Emulator internet access
    By Rz666 in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2013-04-22, 11:14
  2. Bluetooth network for internet access
    By xoratatzis in forum Bluetooth Technology
    Replies: 0
    Last Post: 2005-09-16, 16:26
  3. How to access internet in the internet in the emulator?
    By ccwhk in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2004-11-10, 05:50
  4. [help] can't access network using EPOC emulator
    By dw_huang in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2004-06-11, 19:30
  5. access internet through pc's network connection
    By yinjialiang in forum PC Suite API and PC Connectivity SDK
    Replies: 0
    Last Post: 2003-07-30, 05:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •