×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Jul 2013
    Posts
    73

    Cant build a project in carbide c++ 2.7 sdk s60 maintenace on Vista ultimate 32 bit

    Hello, i just made a new blank project and i wanted to make a test build.

    And i get errors:


    ***Building project "klombex" for configuration "Phone Release (GCCE) [S60_3rd_MR]" //any build set make same errors (as far as i checked)

    ***Printing environment variables modified from default:
    PATH=C:\Symbian\9.1\S60_3rd_MR\epoc32\tools;C:\Symbian\9.1\S60_3rd_MR\epoc32\gcc\bin;C:/Symbian/Tools/Carbide.c++ v2.7/jre/bin/client;C:/Symbian/Tools/Carbide.c++ v2.7/jre/bin;C:\Program Files\Common Files\Symbian\Tools;C:\Program Files\PC Connectivity Solution\;D:\Perl\bin\;C:\Program Files\NVIDIA Corporation\PhysX\Common;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Common Files\Autodesk Shared\;C:\Program Files\QuickTime\QTSystem\;C:\Program Files\CSL Arm Toolchain\bin;C:\Program Files\Satsuki Decoder Pack\Filtres
    EPOCROOT=\Symbian\9.1\S60_3rd_MR\
    NO_DEPENDENCIES=-nd
    MAKE=make -j 4

    Working Directory: D:/temp/klombex/group


    ***Invoking bldmake command
    perl.exe -S bldmake.pl bldfiles gcce
    Proces pr˘bowa? zapisu do nieistniejĄcego potoku. // in translation: Process tried to write into non-existing stream
    WARNING: EPOCROOT does not specify an existing directory
    BLDMAKE ERROR: Directory "\Symbian\9.1\S60_3rd_MR\EPOC32\" does not exist //but i have c:\Symbian\9.1\S60_3rd_MR\Epoc32\ directory

    === BLDMAKE Command failed with error code 1 ===
    ***Stopping. Check the Problems view or Console output for errors.

    ***Errors were detected in build. See the Problems or Console view for details.

    Total Time: 0 sec

    Can someone tell me what i do wrong?

    Cheers.

  2. #2
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,542

    Re: Cant build a project in carbide c++ 2.7 sdk s60 maintenace on Vista ultimate 32 b

    Hhope your workspace and SDK reside on same drive.

    Having said that if you have both SDK and workspace on same drive check http://developer.nokia.com/Community/Wiki/Windows_Vista and http://developer.nokia.com/Community..._Windows_Vista for any clues.

    Edit: Just noticed that your workspace and SDK are indeed on different drives!!

  3. #3
    Registered User
    Join Date
    Jul 2013
    Posts
    73

    Re: Cant build a project in carbide c++ 2.7 sdk s60 maintenace on Vista ultimate 32 b

    well i changed that:
    C:\Program Files\Common Files\Symbian\Tools;

    shouldn't be declared before them. If you get an error like as.exe was called but is not supported in this release then you don't have the path variables set up correctly.
    because that symbian\tools was first (now moved to last position), then i made a new project on the same drive where sdk is installed.

    then i got error, that it cant find 'ICONS_SCALABLE_DC.MK' file: (but i found that file. Iit was named in lowercase so i changed it to ICONS_SCALABLE_DC.MK)


    Anyway i think i have wrong active perl version installed since i get error or warning after executing perl.exe:

    perl.exe anything
    Proces pr˘bowa? zapisu do nieistniejĄcego potoku. // in translation: Process tried to write into non-existing stream
    Because after installing carbide c++ the html page poped up and there was info about version of perl that i should use but i didn't save that page and i can't find it.


    so what version of perl should i use? And another question when i hit Build project button should it create sisx or sis file in the sis directory in project workspace?


    Cheers.
    Last edited by melepeta; 2013-09-17 at 23:31.

  4. #4
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,542

    Re: Cant build a project in carbide c++ 2.7 sdk s60 maintenace on Vista ultimate 32 b

    Version of perl should be 5.6.1 Build 635 which can be downloaded from https://developer.nokia.com/info/sw....ctivePerl.html

  5. #5
    Registered User
    Join Date
    Jul 2013
    Posts
    73

    Re: Cant build a project in carbide c++ 2.7 sdk s60 maintenace on Vista ultimate 32 b

    Actually i can't find a link there, but it seems i have the good one:

    This is perl, v5.6.1 built for MSWin32-x86-multi-thread
    (with 1 registered patch, see perl -V for more detail)

    Copyright 1987-2001, Larry Wall

    Binary build 635 provided by ActiveState Corp. http://www.ActiveState.com
    Built 15:34:21 Feb 4 2003


    Do you have anysuggestions what i have wrong then?



    ===================
    Quick note: Just made my first build, sis and sisx files were made. I did nothing more to make it work.

    Thanks for the help.
    Last edited by melepeta; 2013-09-18 at 08:49.

Similar Threads

  1. Carbide in Vista - unable to create new project!
    By aparna.sr.14 in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2010-03-30, 00:20
  2. Build GCCE with Carbide C++ 2.0 (S60 3rd FP1) on Vista
    By jeffw2003 in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 6
    Last Post: 2009-05-27, 10:11
  3. Replies: 15
    Last Post: 2008-09-11, 21:48
  4. Carbide.vs 3.0 on Vista - can't build release configuration
    By AnthonyAndrews in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 7
    Last Post: 2008-03-29, 18:08
  5. Carbide.c++ and Vista Ultimate
    By izedgo in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 4
    Last Post: 2007-07-24, 11:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×