Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    May 2013
    Posts
    280

    App taking time on device ...but not on degugging.

    I made an s40 app and i somehow manage to reduce the first launch time of app .
    It is taking 1 min 15 sec to launch when i do device debugging but when i installed app on device using data cable and then run it , it is taking approx 3 minutes to run.

    Why is it so?

    Also i noticed(on device debugging) that when device screen is faded after few seconds parsing gets slow but when i tap on device to increase brightness parsing again gets fast.
    I am bit confused on this stuff.

  2. #2
    Regular Contributor
    Join Date
    Dec 2012
    Location
    India
    Posts
    272

    Re: App taking time on device ...but not on degugging.

    Even 1.15 min sounds like a long time! Why is it taking so long ?What operations are you performing at the beginning ?

  3. #3
    Registered User
    Join Date
    May 2013
    Posts
    280

    Re: App taking time on device ...but not on degugging.

    This time i m writing it directly into rms while parsing. I am not using vectors to store.
    Code:
    while (!xmlParsingDone)
       		           {
       		          
       		            
       		             event = parser.read();
       		               ParseEvent pe;
       		               switch (event.getType())
       		               {               
       		                    case Xml.START_TAG:
       		                       // Pick up Title for display
       		                       String tagName = event.getName();
    
    
                                    if ("date".equals(tagName))
       		                      {
       		                        
       		                           pe = parser.read();
       		                           if(pe.getText()!=null)
       		                           {
       		                          th.setdate(pe.getText());           //writing directly
       		                              
       		                          }
    I dont know why it is taking too long. I just tried to test it this way once . And i was very fast as compared to earlier.

    In fact this time i made a separate demo code with no functionality in it other than parsing data and writing in rms.
    Last edited by Manpreet_Singh; 2013-09-28 at 11:59.

  4. #4
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: App taking time on device ...but not on degugging.

    i think the xml data you are getting is large i can see your app will iterate over all the start tags , so if the xml data is large then it will definitely will take more time !!

Similar Threads

  1. Searching is taking a lot of time in rms. what to do?
    By Manpreet_Singh in forum Mobile Java General
    Replies: 4
    Last Post: 2013-06-14, 12:46
  2. code for taking time input
    By yahoo2010 in forum Symbian
    Replies: 1
    Last Post: 2011-01-30, 20:40
  3. mktime is taking longer time
    By vittalx in forum Open C/C++
    Replies: 7
    Last Post: 2009-09-25, 15:22
  4. openPIMList is taking too much time
    By arpit2agrawal in forum Mobile Java General
    Replies: 8
    Last Post: 2008-10-07, 17:56
  5. Replies: 1
    Last Post: 2008-01-28, 20:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×