×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Nov 2013
    Posts
    1

    [Moved]Develop for nokia 6303 classic

    Hi , i'm new to nokia development and I can't seem to figure out what I need to get to develop for 6303 classic , can someone please point me in the right direction ?

    I first tried using QT , but ignoring the fact that it took 6 Gb on my hard , I couldn't put a simple app on my phone , it exported as SIS which my phone doesn't support .
    I then turned to Java , trying the Asha SDK 1.1 because I saw you can change the targeted phone , but after installing the "Series 40 6th Edition SDK" it didn't let me add it to the list , so I couldn't use it .

    I would prefer developing in an environment like the Asha SDK 1.1 because I am more familiar to Java than C++ , and it has LWUIT so making UI's isn't that hard .

    My nokia has symbian 10.12 .
    For the moment I just want to make a simple bluetooth based app for personal use .

  2. #2
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,542

    Re: Develop for nokia 6303 classic

    Quote Originally Posted by nemo9955 View Post
    Hi , i'm new to nokia development and I can't seem to figure out what I need to get to develop for 6303 classic , can someone please point me in the right direction ?
    The device spec page for this device has links to the SDK and supported technology/framework (expand all to see it) https://developer.nokia.com/Devices/.../6303_classic/

  3. #3
    Nokia Developer Champion
    Join Date
    Mar 2013
    Posts
    686

    Re: Develop for nokia 6303 classic

    Your nokia phone doesnt have symbian 10.12 or any other version of it.
    Your phone runs the Nokia propriatery S40 OS (version 6th edition initial release to be exact)
    You can develop apps for it using the standards of J2ME in combination of MIDP2.0 profile and CLDC1.1 platform.
    if you want an IDE you can choose between either Eclipse or NetBeans both of which support j2me Mobile development (Nokia Asha IDE is a modified version of eclipse and since your phone ISNT an asha phone i would suggest you use standard IDE)
    if you wish to use eclipse i would suggest you use this release http://www.eclipse.org/downloads/pac...pers/heliossr2 which is the last one that came with MJT (mobile java tools for j2me)
    There you can use the SDK you installed to test your app on emulator and build your app

  4. #4
    Registered User
    Join Date
    Mar 2003
    Posts
    4,105

    Re: Develop for nokia 6303 classic

    Quote Originally Posted by nemo9955 View Post
    trying the Asha SDK 1.1
    That is the recommended starting point because you get the latest Nokia IDE, as well.
    Quote Originally Posted by nemo9955 View Post
    after installing the "Series 40 6th Edition SDK" it didn't let me add it to the list
    That is the next step, download the emulator which first your device. Good.
    How did you add it? Which error message did you get.
    Quote Originally Posted by nemo9955 View Post
    Nokia 6303 classic
    For this, you should go for the Series 40 5th Edition, Feature Pack 1 because it offers a emulator which fits your screen resolution and is not touch enabled. When everything works in emulator and on device, you should test all (!) other emulators as well, to make sure it runs even in the future.

    Anyway, back to your issue: Why are you not able to add it? Any clue? I had to go back to Java 7 Update 17 (32-bit), just for the runtime (JRE). The JDK did not matter. But the emulator need that JRE. Another trick is explained here. Did that help, already?

Similar Threads

  1. Problem with nokia 6303 classic
    By vlado2121 in forum Audio
    Replies: 1
    Last Post: 2010-09-18, 14:56
  2. Unable to play 3gp files on Nokia 6303 classic using application player
    By supriyaakg in forum [Archived] Flash Lite on Nokia Devices
    Replies: 3
    Last Post: 2010-03-26, 06:17
  3. Help Nokia 6303 classic
    By tinyred in forum Mobile Java General
    Replies: 3
    Last Post: 2010-01-01, 13:14
  4. NOkia 6303 classic
    By jayakrishnan.salim in forum Mobile Java General
    Replies: 3
    Last Post: 2009-12-09, 15:30
  5. [moved] Does Nokia 6303 classic support AT Commands?
    By GM123 in forum General Messaging
    Replies: 1
    Last Post: 2009-07-08, 16:22

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×