×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Regular Contributor
    Join Date
    Mar 2005
    Location
    Hamburg, Germany
    Posts
    285

    Link to nokia store works on emulator, but not on Asha 501

    Hello developers,

    I like to add a link to the store to the about screen of my app, so that the user can download my other apps.
    (Like Nokias UX expert Jan Krebber has suggested)

    This worked with the emulator (Asha SDK 1.0). A web page is displayed with all may apps.

    But when I use it an the phone, there are two things happen:
    1) The App store logo is presented. (A shopping bag on blue ground). So the system has noticed that I link into the shop. This is quite nice.
    2) The shop opens with a generic screen, not with my apps.

    I open the store like this:

    Code:
    platformRequest("http://store.ovi.mobi/publisher/PUBLISHERNAME/");
    How do I make sure that my apps are displayed?
    Should I construct the url in another way?

    My only idea to create a landing page on my own server.
    Do I really need to do this?

  2. #2
    Regular Contributor
    Join Date
    Mar 2005
    Location
    Hamburg, Germany
    Posts
    285

    Re: Link to nokia store works on emulator, but not on Asha 501

    I updated to Asha 1.1.1.
    Problem still there.

    It is also there when I try to put in a link to rate the app.

    And I'm not alone, a Nokia developer Champion has the same problem:
    http://developer.nokia.com/Community...ore-deep-links

    This makes it much more difficult for the user to rate the app.

Similar Threads

  1. Replies: 0
    Last Post: 2013-09-22, 13:12
  2. [moved] S40 application works on stimulator but falis on nokia 300 asha
    By PoojaKaregoudar in forum Nokia Asha Web Apps
    Replies: 9
    Last Post: 2012-03-30, 08:19

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×