×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Jan 2014
    Posts
    7

    Artist.Play doesn't work?

    I have an Artist object (Nokia.Music.Types.Artist) object returned from the API. When I call the PlayMix() method on it, it opens the web browser and redirects back to Nokia Music as expected, but just sits at the application root, rather than going to the Artist mix. I've tried it with a few different artists and the behaviour is the same.

    Amy I doing something wrong here?

    Thanks

  2. #2
    Regular Contributor
    Join Date
    Nov 2007
    Posts
    73

    Re: Artist.Play doesn't work?

    Can you let me know which version of the C# API you are using please?

  3. #3
    Registered User
    Join Date
    Jan 2014
    Posts
    7

    Re: Artist.Play doesn't work?

    Hi,
    I'm using v 2.4 of the SDK obtained via NuGet...

    Thanks

  4. #4
    Regular Contributor
    Join Date
    Nov 2007
    Posts
    73

    Re: Artist.Play doesn't work?

    Please upgrade to v3.1.5 as I made quite a few fixes in this area recently, then let me know how you get on
    Steve

  5. #5
    Registered User
    Join Date
    Jan 2014
    Posts
    7

    Re: Artist.Play doesn't work?

    Unfortunately that doesn't work with WP7 though and this app is a WP7 & WP8 application.

  6. #6
    Regular Contributor
    Join Date
    Nov 2007
    Posts
    73

    Re: Artist.Play doesn't work?

    OK, well I suggest instead of calling Artist.Play, you launch a webbrowser with the WebPlayUriByName from https://github.com/mixradio/wp-api-c...ypes/Artist.cs
    Regards,
    Steve

Similar Threads

  1. S40 6th edition (7230, X2-00): play video file from stream doesn't work
    By thijsman86 in forum Mobile Java Media (Graphics & Sounds)
    Replies: 4
    Last Post: 2011-05-10, 10:16
  2. video doesn't play
    By chandra1234 in forum Symbian
    Replies: 6
    Last Post: 2008-09-29, 12:24
  3. Nokia 5210 BUG: AT+CPBR DOESN'T WORK!! So what other AT cmd doesn't???
    By g3v70 in forum PC Suite API and PC Connectivity SDK
    Replies: 2
    Last Post: 2004-02-20, 14:55
  4. OTA Sound doesn't play all notes
    By michael_madsen@yahoo.com in forum Mobile Java Media (Graphics & Sounds)
    Replies: 2
    Last Post: 2003-12-08, 14:49
  5. Why PC connectivity SDK 2.1 doesn't work while Logomanager work?
    By ngkanto in forum PC Suite API and PC Connectivity SDK
    Replies: 4
    Last Post: 2002-10-15, 05:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×