×

Discussion Board

Results 1 to 13 of 13
  1. #1
    Registered User
    Join Date
    Jan 2014
    Posts
    5

    App Deploy Error - Lumia 1520

    I just bought a Lumia 1520 to start testing my apps, but when I click "Deploy -> Device" I get a timeout error in Visual Studio.
    I have received this error on "Visual Studio Express for Windows Phone" and in "Visual Studio Professional 2013". Express was downloaded from "SDK 8.0" Windows Website and the Visual Studio one was already included when I installed Professional.
    All my services are running, and I can transfer music/videos to my phone from File Explorer.


    Error:
    Error 1 This operation returned because the timeout period expired. 0 0



    My Computer:
    Windows 8.1
    i7(CPU) & 8GB Ram

    Phone:
    Lumia 1520

  2. #2
    Super Contributor
    Join Date
    Feb 2013
    Location
    Dublin, Ireland
    Posts
    585

    Re: App Deploy Error - Lumia 1520

    Which versions of Visual Studio are actually installed? do you have access to Visual Studio 2013 Ultimate?

  3. #3
    Registered User
    Join Date
    Jan 2014
    Posts
    5

    Re: App Deploy Error - Lumia 1520

    Quote Originally Posted by theothernt View Post
    Which versions of Visual Studio are actually installed? do you have access to Visual Studio 2013 Ultimate?
    The highest version I can get is "Visual Studio Professional 2013", which I have installed on my computer already. I get the same error.

    It seems to happens, once the app is deployed from "Application Deployment". I don't have any problems, when deploying app to emulator.

  4. #4
    Super Contributor
    Join Date
    Feb 2013
    Location
    Dublin, Ireland
    Posts
    585

    Re: App Deploy Error - Lumia 1520

    Just to check the basics, have you provisioned the device with the 'Windows Phone Developer Registration' tool? and can you try to deploy from another PC with a fresh install of VS 2013 + WP8 SDK?

  5. #5
    Nokia Developer Moderator
    Join Date
    Feb 2011
    Location
    Portugal
    Posts
    971

    Re: App Deploy Error - Lumia 1520

    Has teothernt specified, you need to have a developer account and use it to Developer Unlock your device using the Windows Phone Developer Registration tool that is installed with the SDK. Only after that you will be able deploy.

    Also make sure you are running your VS.NET instance as Administrator and check is the device is not locked when deploying to it. Usually the IDE will warn you about that, will not throw a timeout error. When deploying check for any messages at the phone.

    Finally some other things to check:
    - Check if your USB connection is working properly. It should be as simple as to try and browse the files on your phone from Explorer.
    - Try a different USB port
    - Disable your Antivirus and see if that solves the problem
    - Check if you have a firewall on, and try to turn it off just to test if that solves the problem

    If everything fails then you may have an issue with yout SDK installation. Its known to happen on rare occasions. To fix that I would recommend a re-install of it.

  6. #6
    Registered User
    Join Date
    Jan 2014
    Posts
    5

    Re: App Deploy Error - Lumia 1520

    Quote Originally Posted by joaocardoso View Post
    Has teothernt specified, you need to have a developer account and use it to Developer Unlock your device using the Windows Phone Developer Registration tool that is installed with the SDK. Only after that you will be able deploy.

    Also make sure you are running your VS.NET instance as Administrator and check is the device is not locked when deploying to it. Usually the IDE will warn you about that, will not throw a timeout error. When deploying check for any messages at the phone.

    Finally some other things to check:
    - Check if your USB connection is working properly. It should be as simple as to try and browse the files on your phone from Explorer.
    - Try a different USB port
    - Disable your Antivirus and see if that solves the problem
    - Check if you have a firewall on, and try to turn it off just to test if that solves the problem

    If everything fails then you may have an issue with yout SDK installation. Its known to happen on rare occasions. To fix that I would recommend a re-install of it.

    USB works, I can transfer files through Explorer.
    I tried all 3 USB ports and used 4 different cords.
    I removed my Avast Antivirus, disabled Windows Defender, and Turned Off Firewall.

    I get the error in the IDE and the "Application Deployment Application"


    I uninstalled all Visual Studio stuff and installed the SDK8.0, and still received the same error.

  7. #7
    Super Contributor
    Join Date
    Feb 2013
    Location
    Dublin, Ireland
    Posts
    585

    Re: App Deploy Error - Lumia 1520

    And you're a registered (and paid up) Windows Phone developer, you can access the Dev Center?

  8. #8
    Registered User
    Join Date
    Jan 2014
    Posts
    5

    Re: App Deploy Error - Lumia 1520

    Quote Originally Posted by theothernt View Post
    And you're a registered (and paid up) Windows Phone developer, you can access the Dev Center?
    My Account is up to date and my phone shows in the registered phones.
    Pictures:



  9. #9
    Super Contributor
    Join Date
    Feb 2013
    Location
    Dublin, Ireland
    Posts
    585

    Re: App Deploy Error - Lumia 1520

    Quote Originally Posted by nicolaskn View Post
    My Account is up to date and my phone shows in the registered phones.
    Pictures: ...
    Thanks, better to confirm that bit

  10. #10
    Nokia Developer Moderator
    Join Date
    Feb 2011
    Location
    Portugal
    Posts
    971

    Re: App Deploy Error - Lumia 1520

    Ok try one last thing.

    Remove your phone on the developer account and register it again. Also make sure that you dont have your app already installed on the phone. If it is remove all references to it. And as a very last resort, if you have a diffrent computer I would try to install the SDK there and try to deploy a simple hello world to it.

  11. #11
    Regular Contributor
    Join Date
    Sep 2012
    Location
    Morocco
    Posts
    298

    Re: App Deploy Error - Lumia 1520

    Please make sure the VS(IDE) language is the same as the WP SDK and your phone language (it might be it)

  12. #12
    Registered User
    Join Date
    Jan 2014
    Posts
    5

    Re: App Deploy Error - Lumia 1520

    FIXED:
    Restarted Phone with it connected to computer. Disabled Hyper-V. Restarted PC with Phone still connected. Now it works!

    Result:
    Successfully deployed app to device via Application Deployment (EXE)
    Successfully deployed debug app to device via Application Deployment .

    The cause is actually unknown. Over the period of the days load time for the files to show in file explorer were getting longer. Yesterday, it showed that my phone was empty when I chose either Phone or SD Card in explorer, even though it showed the remaining space. Tonight I was in the process of installing Vmware & Windows 8.1 Enterprise, when I was forced to restart after disabling Hyper-V. My computer updated, but I checked the update history and the last update installed was 1/7/14, even though it literally just updated 40 minutes ago(1/9/14).



    Possible Problem:
    I think it was probably a driver issue or something un-related to Visual Studio or the SDK.

  13. #13
    Nokia Developer Moderator
    Join Date
    Feb 2011
    Location
    Portugal
    Posts
    971

    Re: App Deploy Error - Lumia 1520

    It may also be related with Hyper-V somehow. But I agree that a driver makes more sense.

    Thanks for sharing!

Similar Threads

  1. Lumia 1520 highest cam resolution not working in my app
    By protonhead in forum Windows Phone Imaging
    Replies: 6
    Last Post: 2013-11-29, 16:04
  2. Cannot deploy Phoneapp1 to my lumia 920
    By wlab in forum Windows Phone General
    Replies: 14
    Last Post: 2013-05-30, 23:23
  3. App doesn't deploy after tombstoning on Lumia 900
    By lemieux in forum Windows Phone General
    Replies: 3
    Last Post: 2012-05-16, 12:54
  4. Web App Deploy - Communication Error
    By awdrenfontao in forum Nokia Asha Web Apps
    Replies: 1
    Last Post: 2011-05-27, 04:59
  5. Error when trying to deploy
    By dfjones in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2009-10-03, 07:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×