×

Discussion Board

Results 1 to 14 of 14
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    1

    NMB4 : how to change user agent ?

    With NMB i connect OK to a provider gateway. But the host identifies NMB like a minimum browser, and doesn't send images. I need to force NMB to identify itself as an advanced browser so that the host sends full script and images.
    I tried using the header settings : name "Advanced", value "SHARP-TQ-GX10/1.0" which i know as a typical advanced user agent. But it has no effect from the host point of view : i still receive only B&W data without images.

    How the user agent must be passed ?

  2. #2
    Registered User
    Join Date
    Apr 2003
    Posts
    4
    The header you need to set is "User-Agent".

    We are finding however that it does not always work - on two machines at least you set it up but it is not passed through to the web server. We are still trying to work out what is the common factor on the two machines on which it does not work.

  3. #3
    Registered User
    Join Date
    Mar 2003
    Posts
    111
    Related posting on changing headers:

    Do make sure after entering new headers and values, click on some other row of the table (i.e., get the focus out of that cell), before you click Apply or OK. Otherwise the changes may not get applied. Also make sure the leftmost checkbox is checked so that your new header will be sent out on a request.

    -Vishu, Toolkit team

  4. #4
    Registered User
    Join Date
    Apr 2003
    Posts
    4
    Thanks Vishu. However we are aware of these gotchas, having been using the Version 3 browser for a long time. The situation on my machine is that even after re-starting the toolkit the newly entered value for "Accept-Header" is not sent.

  5. #5
    Registered User
    Join Date
    Apr 2003
    Posts
    11
    Does it show up in the diagnostics? How about the device settings? Does it seem to be there, but is not sent, or does it even disappear from the device settings after you restart?

  6. #6
    Registered User
    Join Date
    Apr 2003
    Posts
    4
    The request headers are not being overridden by those I have set up. For example, currently I have a header configured for "User-Agent" of "Nokia6210", and "Accept-Language" of "en", but diagnostics show the default values being sent.

    My header settings survive toolkit re-starts, and the problem has been experienced on a number of different machines - roughly half of those we have tried so far.

    I have been trying to find a pattern (common OS, JRE versions, etc), but so far have not spotted it.

    Have had to switch back to version 3.1 for real work, which is a shame.

  7. #7
    Registered User
    Join Date
    Mar 2003
    Posts
    1
    I have the same issue.
    At work, it works, at home it does not.
    At home I installed it over, or while version 3 was still there, work installation was done to a new machine which did not have any previous version of Nokia Toolkit.

    Maybe this is the issue, or maybe not, but sure is a pain in the as$.

    I am running WinXP prof at home, anyone out there with WinXP that is not experiancing this issue?
    Last edited by eplur; 2003-07-30 at 11:52.

  8. #8
    Registered User
    Join Date
    Aug 2003
    Posts
    3
    I have the same problem, I cannot update the user agent. I'm running toolkit 4.0 under windows 2000 pro.
    I have found a file containing the information about the user agent (nmb40.prefs) but changing the value doesn't have any effect. I'll try to install one of those Nokia simulator in order to see if they adapt the user agent.

  9. #9
    Registered User
    Join Date
    Aug 2003
    Posts
    3
    I have just tried under windows millenium and it works perfectly

  10. #10
    Registered User
    Join Date
    Apr 2003
    Posts
    4

    We have not found any OS-related pattern

    For example, we have a number of Win2K machine on which it works, and others on which it does not.

    One of the team found that by manually removing all traces of the 3.1 version prior to installing the 4.0 version he could get it working, but this solution did not work for me.

  11. #11
    Registered User
    Join Date
    Aug 2003
    Posts
    3
    This is very strange, I had installed 3.1 on both of my computers.
    On the one using Windows 2000 pro, I can't update custom headers but I can update x-nokia headers. On the other computer using Windows Millenium, I can update custom headers and simulate any handset but impossible to modify a x-nokia. Each time I try to modify x-nokia-msisdn, the simulator crashes and I have to restart it, of course it didn't record my modification.

    any idea of how I can modify accept types ? Accept types which are being sent are those of the simulator and not those corresponding to the simulated handset.

  12. #12
    Registered User
    Join Date
    Sep 2003
    Posts
    1
    Still no answer for this problem?
    Does anyone know a walk around for this issue?
    Nokia?
    Anyone..?

  13. #13
    Registered User
    Join Date
    Oct 2003
    Posts
    1
    I have the same problem. I'm running NMB 4 on a machine that previously didn't have a version on it.

    Custom headers simply don't work. Very frustrating.

    Tom

  14. #14
    Registered User
    Join Date
    Oct 2003
    Location
    Belgium
    Posts
    9
    I'm working on a Windows 2000 machine and it looks like working properly, although I have to restart the Nokia Mobile Browser after editing the header, but after that it works.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×