×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Jan 2014
    Posts
    1

    Question NFC issue in Lumia 820 developer device with Amber and GDR 3 preview

    I have a Nokia Lumia 820 device. While I run NFC test app to it, the output window shows exited with code 259 (0x103)

    Full debug output is

    Code:
    'TaskHost.exe' (CLR C:\windows\system32\coreclr.dll: DefaultDomain): Loaded 'C:\windows\system32\mscorlib.ni.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
    'TaskHost.exe' (CLR C:\windows\system32\coreclr.dll: Silverlight AppDomain): Loaded 'C:\windows\system32\System.Windows.RuntimeHost.ni.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
    'TaskHost.exe' (CLR C:\windows\system32\coreclr.dll: Silverlight AppDomain): Loaded 'C:\windows\system32\System.Windows.ni.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
    'TaskHost.exe' (CLR C:\windows\system32\coreclr.dll: Silverlight AppDomain): Loaded 'C:\windows\system32\System.Net.ni.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
    'TaskHost.exe' (CLR C:\windows\system32\coreclr.dll: Silverlight AppDomain): Loaded 'C:\windows\system32\System.ni.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
    'TaskHost.exe' (CLR C:\windows\system32\coreclr.dll: Silverlight AppDomain): Loaded 'C:\windows\system32\System.Xml.ni.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
    'TaskHost.exe' (CLR C:\windows\system32\coreclr.dll: Silverlight AppDomain): Loaded 'C:\Data\Programs\{D86D77EF-53AA-4B7D-95C4-450B169C3814}\Install\Test NFC.DLL'. Symbols loaded.
    'TaskHost.exe' (CLR C:\windows\system32\coreclr.dll: Silverlight AppDomain): Loaded 'C:\windows\system32\Microsoft.Phone.ni.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
    'TaskHost.exe' (CLR C:\windows\system32\coreclr.dll: Silverlight AppDomain): Loaded 'C:\windows\system32\Microsoft.Phone.Interop.ni.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
    'TaskHost.exe' (CLR C:\windows\system32\coreclr.dll: Silverlight AppDomain): Loaded 'C:\windows\system32\System.Core.ni.dll'. Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
    The thread 0x7b8 has exited with code 259 (0x103).
    The thread 0x80c has exited with code 259 (0x103).
    My app code is

    Code:
    var proximityDevice = Windows.Networking.Proximity.ProximityDevice.GetDefault();
                if (proximityDevice != null)
                {
                    MessageBox.Show("YES"); 
                }// at least one proximity device installed } 
                else
                {
                    MessageBox.Show("NOOOOO");
                }
    I am with Amber update and in GDR3 preview. and take a look at this screen also. enter image description here

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,572

    Re: NFC issue in Lumia 820 developer device with Amber and GDR 3 preview

    If you simply search for exit code 259 with Google, you will find some hints. It is a thread "exit code" which actually means that the thread is still running.
    Does your code work otherwise? Remember that you need a capability for executing this method (see documentation http://msdn.microsoft.com/en-us/libr...ice.getdefault).

Similar Threads

  1. Charging issues with developer device(Lumia 800)
    By mrudulpen in forum Windows Phone General
    Replies: 9
    Last Post: 2014-02-17, 01:19
  2. Developer Device (Lumia 820, 920) Update
    By WopeKit in forum Feedback - Nokia Developer Services & Infrastructure
    Replies: 34
    Last Post: 2014-02-06, 15:36
  3. Replies: 7
    Last Post: 2013-05-07, 06:54
  4. My Lumia 800 developer device screen issue
    By pigling in forum Windows Phone General
    Replies: 4
    Last Post: 2012-09-16, 12:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •