×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jun 2012
    Posts
    3

    Backbutton command issue in Asha with Lwuit

    Hi, I am developing for Asha 501 using Lwuit.
    I´m having a weird issue: randomly the back command assigned to the hardware back button is showed in the commands list. When this happens, the hardware button has no functionality and the command is needed to be activated from the command in the command menu list. This happens once when the app has been launched more than five o six times approx. The other times the app works properly. Does anyone know how to fix this o why does it happen??

    The code for declaring tha back command is this:

    Command backCommand = new Command("back") {

    public void actionPerformed(ActionEvent evt) {
    super.actionPerformed(evt);
    back();
    }
    };

    setBackCommand(backCommand);



    Thanks in advance!!

  2. #2
    Nokia Developer Champion
    Join Date
    Mar 2013
    Posts
    608

    Re: Backbutton command issue in Asha with Lwuit

    I don't think you need both the super.actionPerformed() call
    and your back() call
    you need to decide where you want to handle the back action
    either in the command actionPeformed method
    or the commandListener of the form.
    Heard of DVLUP? Join here

  3. #3
    Registered User
    Join Date
    Jun 2012
    Posts
    3

    Re: Backbutton command issue in Asha with Lwuit

    Ok, the problem is not handling the backbutton. The problem is that the command sometimes is assigned to the hardware back button of the device, and sometimes it is displayed in the commandmenu of the form. When it is displayed in the Command menu of the form, the back command only works when tapping it on the menu and not on the physical button.

  4. #4
    Nokia Developer Champion
    Join Date
    Mar 2013
    Posts
    608

    Re: Backbutton command issue in Asha with Lwuit

    if the problem is what you say it is then provide more detailed code about how, where & when you show the form and set its command because for me the code of setting backcommand works every time with the physical back key on the new ashas.
    Heard of DVLUP? Join here

Similar Threads

  1. LWUIT TextField issue (Asha FullTouch )
    By bogus40 in forum Mobile Java UI and User Experience
    Replies: 6
    Last Post: 2014-03-21, 08:22
  2. Wifi issue on Asha 503 (Asha software platform 1.1)
    By robert_czw in forum Mobile Java Networking & Messaging & Security
    Replies: 3
    Last Post: 2014-01-31, 20:00
  3. Nokia Asha 501 LWUIT (Asha SDK 1.0) setScrollable(false) not having an effect
    By Gureen.Ryuu in forum Mobile Java UI and User Experience
    Replies: 1
    Last Post: 2013-10-30, 11:14
  4. Which LWUIT plugin for Asha SDK 1.0
    By bogus40 in forum Mobile Java UI and User Experience
    Replies: 5
    Last Post: 2013-07-06, 11:48
  5. Issue in loading images into command in lwuit for nokia s40
    By rchadalawada in forum Mobile Java General
    Replies: 13
    Last Post: 2013-03-08, 09:31

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •