×

Discussion Board

Results 1 to 3 of 3

Thread: user detect

  1. #1
    Registered User
    Join Date
    May 2003
    Posts
    32

    user detect

    Hi im using this script for directing users from my homepage.

    When testing NMIB, Its no go, any ideas thanks Paul


    <%
    If (InStr(Request.ServerVariables("HTTP_ACCEPT"), "text/vnd.wap.wml")) then
    Response.Redirect("mtaxi.wml")
    Else
    ' Uncomment the line below when HTML form is in place
    ' Response.Redirect("mtaxi.htm")
    Response.Write("xhtml form page")
    End If
    %>

  2. #2
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Singapore
    Posts
    101
    Hi,

    Perhaps you can try setting the content type in response :

    Response.ContentType = "text/vnd.wap.wml"


    Best Regards,
    Valerie / Forum Nokia

  3. #3
    Registered User
    Join Date
    May 2003
    Posts
    32
    Hi Valerie,

    This code when tested locally using NMBS 4 works fine! as to does the 7210.
    Testing off my host server all is not well, 7210 returns file not found the NMBS returning error 400 bad request.
    My host assures me the mime types are installed because the openwave sdk redirects me to the mtaxi.wml page this is true.
    I can only think it is somthing to do with Nokia and the script.
    Any help out there cheers Paul

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×