Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Apr 2013
    Posts
    7

    Exclamation Nokia S40 6th Edition SDK error

    Hi!
    I have download Nokia S40 6th Edition SDk from your website but I am facing problem to start Nokia S40 6th Edition SDK Emulator. Java Development Kit & Public JRE v1.7.25 on Windows 7 operating system, when i execute Emulator, Emulator gives the error is that The Internal RMI registry port 1099 may be in used by another application then I change RMI registry port 1099 to 2001 but I am facing the same problem.
    Please give the solution for this error.

    Thanks!

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,791

    Re: Nokia S40 6th Edition SDK error

    Older SDK-s are tested with older JDK-s.
    You can read a possible workaround in #40 of http://developer.nokia.com/community...ry-port-number

  3. #3
    Registered User
    Join Date
    Apr 2013
    Posts
    7

    Re: Nokia S40 6th Edition SDK error

    Hi!
    I read workaround of SDK. I realized that I have to install JDK 6 for this. In which version of JDK 6 is suitable for Nokia S40 6th Edition SDK?

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,791

    Re: Nokia S40 6th Edition SDK error

    If we talk about the same workaround (starting the RMI daemon manually), I am pretty sure that it is about Java 7. For Java 6, you probably will not need any workarounds, so you can try with the most recent one.

  5. #5
    Registered User
    Join Date
    Mar 2003
    Posts
    4,105
    Does this help?
    Works here with the latest Java 7. If not, please say so, then you face another issue.
    Quote Originally Posted by wizard_hu_ View Post
    If we talk about the same workaround (starting the RMI daemon manually), I am pretty sure that it is about Java 7. For Java 6, you probably will not need any workarounds, so you can try with the most recent one.
    The latest versions of Java 6 raise this issue as well.
    Quote Originally Posted by pkg_88 View Post
    In which version of JDK 6 is suitable for Nokia S40 6th Edition SDK?
    Java 6 Update 43
    Anyway, I recommend the above trick because it works with the recent Java versions. If you do not want to go for that, another one is to start one of the latest Asha Software Platform emulators. After that, all previous Series 40 emulators work, as well.
    Last edited by traud; 2014-03-08 at 14:13.

Similar Threads

  1. (SDK doesn't start)Getting error in NOKIA SDK series 40 6th edition FP 1
    By ravi.joshi53 in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2011-11-17, 22:34
  2. Replies: 0
    Last Post: 2009-01-07, 12:49
  3. Replies: 1
    Last Post: 2007-06-10, 14:29
  4. Error with S60 2nd edition FP1
    By rakesh.jaiswal in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2005-05-19, 18:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×