×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Oct 2013
    Posts
    22

    TileSource offline with StreamSocketListener not working on Lumia, but ok on Ativ S

    Following this thread, it came out that this is a Map-Control-issue, not a StreamSocketListener -problem. So we are back in this forum.

    I'm loading locally stored map-tiles from a TileSource in the Map-Control. This works fine, but not on Lumia-Phones, if there is no network connection. On Samsung Ativ S its still working. On Samsungs it was also not working before the GDR3-update. On Lumias its not working even with the Black-firmware.

    Attached is a project to reproduce.
    Just run the app and there should appear some red "suns" on the map, which are my locally stored tiles.
    Turn off network, e.g. activate airplane-mode, run the app again and there are no "suns" anymore.

    Try on a Samsung and you'll see that there are still the red suns.

    I think, there must be something different in the GetUri-Overload of the Map-control on Lumias, when not connected.
    Tom

    http://files.qvgps.com/software/qvm/...tilesnokia.zip

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: TileSource offline with StreamSocketListener not working on Lumia, but ok on Ativ

    Hmm, I just tried with my 920 in flight mode and the "suns" are still showing. I will try some more thorough testing as soon as I can find some time ... Until then it would be good if others could contribute their observations, with both Lumia Amber and Lumia Black firmware eventually.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Registered User
    Join Date
    Oct 2013
    Posts
    22

    Re: TileSource offline with StreamSocketListener not working on Lumia, but ok on Ativ

    What os-version is it actually showing on your 920?
    My 520 has 8.0.10521.155, same as my Ativ S
    There might be some caching in the map-control, so better finish app when changing flightmode-setting.
    Tom

  4. #4
    Registered User
    Join Date
    Oct 2013
    Posts
    22

    Re: TileSource offline with StreamSocketListener not working on Lumia, but ok on Ativ

    Is there actually a way to get official support from Nokia ?
    Tom

  5. #5
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,750

    Re: TileSource offline with StreamSocketListener not working on Lumia, but ok on Ativ

    http://developer.nokia.com/support used to list such things, you could simply buy support tickets in the past. Right now there are no such channels available immediately, feedback may be the closest one.
    If you happened to be in the Lumia Premium Developer Program, just have not checked it in detail, that included 2 support tickets or so. However the program is ramped down, so you can not join now.
    Other existing option seems to be the "Earn support tickets through DVLUP", but I can not imagine how they think that - e.g. getting support after you succeeded with your project(s).

  6. #6
    Registered User
    Join Date
    Oct 2013
    Posts
    22

    Re: TileSource offline with StreamSocketListener not working on Lumia, but ok on Ativ

    Thats not really much.. So I can only hope, that someone here might find a trick.
    Thx, Tom

  7. #7
    Registered User
    Join Date
    Oct 2013
    Posts
    22

    Re: TileSource offline with StreamSocketListener not working on Lumia, but ok on Ativ

    Quote Originally Posted by ltomuta View Post
    Hmm, I just tried with my 920 in flight mode and the "suns" are still showing. I will try some more thorough testing as soon as I can find some time ... Until then it would be good if others could contribute their observations, with both Lumia Amber and Lumia Black firmware eventually.
    Lucian, flightmode is actually not the issue. We realized, that activating flightmode on the ground doesn't automatically disconnect you.
    This Lumia-bug with TileSources occurs when not connected to the internet, so please switch off wifi and gsm-data and try again.

    Tom

  8. #8
    Registered User
    Join Date
    Oct 2013
    Posts
    22

    Re: TileSource offline with StreamSocketListener not working on Lumia, but ok on Ativ

    Hello.. ?

Similar Threads

  1. StreamSocketListener not working on Lumia, but Ok on Samsung Ativ
    By Tom_nam in forum Windows Phone General
    Replies: 15
    Last Post: 2014-02-20, 12:24
  2. Nokia Lumia issues (call drops, skype, tethering, offline navigation)
    By overrider in forum General Development Questions
    Replies: 1
    Last Post: 2012-01-13, 08:54
  3. Pyhton Apps not working in offline mode
    By shsaad in forum Symbian
    Replies: 1
    Last Post: 2011-10-28, 17:31
  4. App is not working in offline mode
    By tarun.WRT in forum Symbian
    Replies: 1
    Last Post: 2011-01-08, 11:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×