Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    May 2003
    Posts
    6

    Wrong song plays for 2 seconds before MixRadio plays correctly

    Hi,
    I'm using the MixRadio seeded mixes in my app (i.e., Artist.WebPlayUri). I'm finding an odd problem: when I load the URL, a song starts playing (normally not by the specified artist). It plays for about 2 seconds, though that may depend on connection speed. Then, after the page finishes loading, it switches to a new song. This new song plays for 30 seconds as expected and then changes to the next song, which also plays for 30 seconds. From then on, it works properly.
    The problem occurs both on the phone and with a normal PC, so I managed to collect a network trace with Fiddler. http://1drv.ms/MSUmwR
    There's also a screenshot at http://1drv.ms/MSUWdU.
    Notice especially frames 10, 17, and 29, the music files. Frames 10 and 17 are separated by 1 second (See Date header on response). Then frame 29 occurs 30 seconds later.
    As you can see from the Fiddler file, I'm using URLs like http://www.mixrad.io/us/en/mixes/see...David%20Guetta . Is there something special I need to do to avoid this 2-second sample? I'm using WebBrowser, so I have InvokeScript, but I haven't come up with a workaround that works reliably. Is this a bug in the website?
    Thanks

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,791

    Re: Wrong song plays for 2 seconds before MixRadio plays correctly

    Just out of curiosity: can you recognize that extra 2 second thing? Is it maybe a part of the last song you have listened to previously? I could think of a rolling buffer somewhere which gets (re)played before new data becomes available.

  3. #3
    Registered User
    Join Date
    May 2003
    Posts
    6

    Re: Wrong song plays for 2 seconds before MixRadio plays correctly

    Thanks for your reply. I checked and the song is not the same as the one before. The name of the song actually shows up, so I didn't have to try to recognize it

  4. #4
    Nokia Developer Expert
    Join Date
    Feb 2014
    Posts
    29

    Re: Wrong song plays for 2 seconds before MixRadio plays correctly

    Hi, can you share with me some of the URLs you're using where you see this problem please?
    That way we can narrow the problem down a bit.
    Regards,
    Steve

  5. #5
    Registered User
    Join Date
    May 2003
    Posts
    6

    Re: Wrong song plays for 2 seconds before MixRadio plays correctly

    Steve,
    Thanks for looking into this. The URL I gave as an example (http://www.mixrad.io/us/en/mixes/see...David%20Guetta) demonstrates the issue. It seems to be more noticeable with a slower connection to the internet. I think if you connect fast enough, the first song may not play, though you can definitely see it being loaded.

  6. #6
    Nokia Developer Expert
    Join Date
    Feb 2014
    Posts
    29

    Re: Wrong song plays for 2 seconds before MixRadio plays correctly

    OK, thanks, I'll discuss with our web team and get back to you.
    Regards,
    Steve

  7. #7
    Nokia Developer Expert
    Join Date
    Feb 2014
    Posts
    29

    Re: Wrong song plays for 2 seconds before MixRadio plays correctly

    I'm pleased to say this has now been fixed by our web team.
    Regards,
    Steve

  8. #8
    Registered User
    Join Date
    May 2003
    Posts
    6

    Re: Wrong song plays for 2 seconds before MixRadio plays correctly

    Thanks a bunch!

Similar Threads

  1. sound plays with delay on 5th
    By schmeichel in forum Symbian
    Replies: 1
    Last Post: 2010-12-20, 10:38
  2. Replies: 6
    Last Post: 2007-07-27, 09:53
  3. Sound plays with delay
    By inamru in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2007-05-30, 19:11
  4. 6280 plays wav in j2me
    By gootsing in forum Mobile Java Media (Graphics & Sounds)
    Replies: 7
    Last Post: 2007-04-12, 10:25
  5. MIDI plays slower on device?
    By yonan32 in forum Mobile Java Media (Graphics & Sounds)
    Replies: 0
    Last Post: 2003-07-29, 11:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×