Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Aug 2013
    Posts
    4

    How to publish WP8 App(created under WP8 environment) on WP8.1 device

    I am trying to test my WP8 application on WP8.1 device using Beta distribution. When i send the link to WP8.1 device it is saying no application exists although working fine with WP8 device. I believe there seperate store for WP8 and WP8.1 and i have deployed the app in WP8 store.

    Is there any way to install WP8 app on WP8.1 device ?

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,798

    Re: How to publish WP8 App(created under WP8 environment) on WP8.1 device

    According to a search for wp 8.1 preview store access there have been indeed some issues, but generally installation is expected to work from the Store now. As it is your application you can also try deploying locally, from your PC as a workaround.

  3. #3
    Super Contributor
    Join Date
    Feb 2013
    Location
    Dublin, Ireland
    Posts
    590

    Re: How to publish WP8 App(created under WP8 environment) on WP8.1 device

    To second what wizard_hu_ is saying, Windows Phone 8 apps can be deployed via beta distribution or on devices running Windows Phone 8.1 - this is what I currently do.

    When submitting a beta to the store, it can take a few hours before the link to the store will actually work. Typically I submit in the evening, and email my testers the next day to ensure everyone will be able to download the app.

    If you're in a hurry, use on-device testing

  4. #4
    Nokia Developer Champion
    Join Date
    Mar 2013
    Posts
    529

    Re: How to publish WP8 App(created under WP8 environment) on WP8.1 device

    To add to that: different devices might hit different servers so one device might see the App already while another does not. Just try again today and it should be available on both now. If the issue still persists I'd suggest contacting the Store Support Team and ask directly.

Similar Threads

  1. Replies: 4
    Last Post: 2009-10-30, 14:14
  2. Set/Get BT Device Class using Publish&Subscribe API
    By ken_kusagi in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2005-07-06, 11:23
  3. WorkSpace not created in VC environment
    By unsgm in forum Symbian Tools & SDKs
    Replies: 3
    Last Post: 2003-12-21, 21:17
  4. File not created on the device?
    By techno2003 in forum Symbian User Interface
    Replies: 3
    Last Post: 2003-09-26, 04:34

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×