×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    113

    N3650 can not play sound to telephony uplink? 7650 can!

    Hi all,

    It seems that the Nokia 3650 is not capable to play any locally stored sound to the telephony uplink. But, the 7650 is. I used both classes

    CMdaAudioPlayerUtility
    CMdaAudioRecorderUtility

    since they are both capable to play stored sounds.

    On a 7650 everthing works well, the sound is noticeable locally and it is played to the uplink too, sinces on the other side of the phone line it can be heard. When using a 3650 with the very same symbian code loaded on it, it plays the sound locally, but no sound can be heard on the other end of the call.

    Has anybody ever faced this problem too?

    Any answers are most welcome. Thanks, Marcel

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    42
    I ran into the same problem. Nor standard voice recorder application, nor my custom player could not play message in the 3650 telephony uplink. On 7650 everything works great. (I'm using CMdaAudioRecorderUtility with ETelephonyNonMixed device mode).
    This is very important to know if this is impossible to play voice clips in the 3650s telephone uplink. Please advice.

    Regards,

    David

  3. #3
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    113
    Hi David,

    > ETelephonyNonMixed device mode).

    I could not see, that using different Mix-Modes have an impact on how the sound is routed, regardless which phone (N3650 or N7650) i use. However, this could be a more general bug in either symbian or Nokia's firmware.

    > the 3650s telephone uplink. Please advice.

    I'm still not having a solution on this. But i have heard, that someone using N3650 with firmware v2.16 was able to play sounds to the uplink. All my 3650 phones (3 pieces) all have firmware v2.50 and are not able to play sounds to the uplink.
    What firmware does your phone have? (press *#0000# while the phone app is active).

    Thanks, Marcel

  4. #4
    Registered User
    Join Date
    Mar 2003
    Posts
    42
    The firmware version is 2.54, I think that this problem can be solved. Would be glad to hear Nokia experts comment on this subject. Again, this is very important to know what is exactly going wrong.

    Regards,

    David

  5. #5
    Registered User
    Join Date
    Mar 2003
    Posts
    42
    It seems that in 3.12 firmware and higher this bug is fixed. This is fatal bug for some kind of applications. Just wanted to know how many 3650 with such bugged firmwares (less than 3.12) are bringed to the market.

    Regards,

    David

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •