I have application, which connects to server on simulator 7210 it is OK, it connects on 127.0.0.1 with no problem and no questions.

Code:
conn = (HttpConnection) Connector.open(url);
conn.setRequestMethod(HttpConnection.POST);
conn.setRequestProperty("Content-Length", Integer.toString(request.length()));
out = conn.openOutputStream();/******1*****/
int requestLength = request.length();
for (int i = 0; i < requestLength; ++i) {
   out.write(request.charAt(i));
}
in = conn.openInputStream();/********2*******/
but in series 60 emulator it asks me at point **1** to choose
Direct PPP or RAS PPP. After that( I choose any of them) it will raise Exception in point **2** with name:java.io.IOException: Status = -21 bellow is whole stacktrace if it helps.
Now, whats wrong? I used 127.0.0.1, real IP, localhost as parameter and it was working on 7210. Do I have to setup something in emulator my program to work? Or is it a bug? feature?? Am I doing something wrong??




only stack trace follows:
[Info] Series 60 MIDP SDK for Symbian OS version 1.2: java.io.IOException: Status = -21
[Info] Series 60 MIDP SDK for Symbian OS version 1.2: at com.symbian.cldc.connection.ConnectionEndPoint.writeBytes(+140)
[Info] Series 60 MIDP SDK for Symbian OS version 1.2: at com.symbian.cldc.connection.OutputStream.flush(+23)
[Info] Series 60 MIDP SDK for Symbian OS version 1.2: at com.symbian.midp.io.protocol.http.HttpConnection.sendRequest(+101)
[Info] Series 60 MIDP SDK for Symbian OS version 1.2: at com.symbian.midp.io.protocol.http.HttpConnection.ensureResponse(+40)
[Info] Series 60 MIDP SDK for Symbian OS version 1.2: at com.symbian.midp.io.protocol.http.HttpConnection.openDataInputStream(+15)
[Info] Series 60 MIDP SDK for Symbian OS version 1.2: at com.symbian.midp.io.protocol.http.HttpConnection.openInputStream(+4)
[Info] Series 60 MIDP SDK for Symbian OS version 1.2: at wildwest.HttpPoster.doSend(+222)
[Info] Series 60 MIDP SDK for Symbian OS version 1.2: at wildwest.HttpPoster.run(+102)