×

Discussion Board

Results 1 to 13 of 13
  1. #1
    Registered User
    Join Date
    Mar 2003
    Location
    California
    Posts
    11

    How to make an internet connection using Series60 MIDP SDK for Symbian_OS v1.2 emulor

    How to make an internet connection using Series_60_MIDP_SDK_for_Symbian_OS_v_1_2 Emulator

    Thanks

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    33

    I am also looking for the same thing

    Can anyone explain?


    Yashodhan

  3. #3
    Registered User
    Join Date
    May 2003
    Location
    Tropical Paradise Penang
    Posts
    43

    Me too...

    I'm also having the same problem... can anyone help us?

  4. #4
    Registered User
    Join Date
    Mar 2003
    Posts
    33

    Success!I have done it.

    Hi Friends,

    At last I could do it.The procedure for an internet connection using Series_60_MIDP_SDK_for_Symbian_OS_v_1_2is as given below.

    1 Open the Emulator by running
    "epoc32\release\wins\udeb\epoc.exe"

    2 On the screen go to Configuration->settings->Connection
    ->Access Points
    3 If you are not under any proxy server,

    Check that it is DirectHttp.

    To make it Direct HTTP, run Direct_HTTP_Current.cmd from command promt which is available in \bin\Series_60_MIDP_SDK_for_Symbian_OS_v_1_2_1.
    Also confirm your internet is on & you have a WAP gateway IP which is put inside Direct HTTP settings.

    4 If you are under a firewall / proxy,

    Install Nokia Wap Gateway Simulator 4.0 on your Machine.Set its proxy settings & passwords.
    Now once again on the screen go to Configuration->settings
    ->Connection->Access Points. Create a new access point using default settings. Put the IP of your installed WAP gateway inside your access point settings.As your proxy password is set in Wap gateway simulator, password setting in access point is actually immaterial.But give the same username & password as your proxy here also.

    That is all your setting is over.

    Now on the emulator screen go to services->add bookmark.
    add url such as http://wap.yahoo.com & confirm that the access point is the one you created.Once again give your proxy username & password.

    Save it by clicking back.

    Now click on the bookmark you created & say OK.

    See,you are connected to internet.



    Yashodhan.

  5. #5
    Registered User
    Join Date
    May 2003
    Location
    Tropical Paradise Penang
    Posts
    43

    How about J2ME application?

    This work on J2ME application as well?

  6. #6
    Registered User
    Join Date
    Mar 2003
    Posts
    33

    Not sure!

    I am also trying same thing.


    If you are through, please tell me also!

    Yashodhan

  7. #7
    Registered User
    Join Date
    May 2003
    Location
    Tropical Paradise Penang
    Posts
    43
    Actually I can connect my J2ME application to my web server using Series 60 MIDP v0.2 Beta.

    But when I use Series 60 v1.2 I can't.

  8. #8
    Registered User
    Join Date
    Mar 2003
    Posts
    33

    can connect Series_60_v_1_2 Emulator

    Hi,

    I can also connect this Series_60_v_1_2 Emulator to a server residing on my machine just by creating a bookmark for localhost.

    Just now I could also make a connection through J2ME application.

    Yashodhan

  9. #9
    Registered User
    Join Date
    May 2003
    Location
    Tropical Paradise Penang
    Posts
    43
    Using the same Connection setting u did for the Internet connection?

    Have to connect to a WAP Gateway? Can connect direct thru Internet without using a WAP gateway?

  10. #10
    Registered User
    Join Date
    Mar 2003
    Posts
    33

    Yes!!

    Hi,

    You have to use the wap gateway.Bypass it for local addresses if you are under proxy in its settings.


    Yashodhan

  11. #11
    Registered User
    Join Date
    May 2004
    Posts
    18

    I can't connect Series_60_MIDP_SDK_for_Symbian_OS_v_1_2 emulator to Internet

    Hi,

    yashodhan

    I config the Series_60_MIDP_SDK_for_Symbian_OS_v_1_2 as you said.But I still can't connect.

    My computer does not use proxy. And I set the WAP gateway address. And I tried all the three kind of Bearer type. How to set the Access number? I just tried 8000 and 8080.

    Does anybody know how to connect Series_60_MIDP_SDK_for_Symbian_OS_v_2.0 to Internet? Thank you.

    Ning

  12. #12
    Registered User
    Join Date
    Mar 2003
    Posts
    33

    Run Direct_HTTP_Current.cmd

    Hi Ningdai,

    Run Direct_HTTP_Current.cmd from command promt which is available in \bin\Series_60_MIDP_SDK_for_Symbian_OS_v_1_2_1.

    It will automatically create an access point "DirectHttp" in your emulator in Configuration->Settings->Connection->Access Point.

    Do Not Edit this access point.

    Just Make it defaul.

    Try this out.


    Yashodhan

  13. #13
    Registered User
    Join Date
    May 2004
    Posts
    18

    no valid access point available

    Hi,

    If I do not adit the access point, the gateway has not been set, it is 0.0.0.0

    Then I try the bookmark, it shows that no valid access point available.

    Ning

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×