×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Aug 2003
    Posts
    3

    D211 & ZyXEL WLAN AP's, problem when Network name is hidden

    D211 seems to have problem with ZyXEL WLAN APs, basicly no matter with which ZyXEL model.

    Everything works just fine when SSID is not hidden, D211 can find wireless network and associate with it properly with correct speed.

    But when (E)SSID is hidden in AP configuration, D211 can not associate with it anymore. SSID, channel, speed, etc. are all entered properly to D211 configuration, and link is even created but there is no data going though at all.

    And when (E)SSID is set not to be hidden in AP, everything works again just great.

    ZyXEL uses Intersil chips/pcmcia-cards built-in in current 802.11b APs. D211 driver version is 4.33

    I can provide different ZyXEL APs for interop. testing if needed.

  2. #2
    Registered User
    Join Date
    Aug 2003
    Posts
    3
    Just want to add that there is nothing propiertary implemented in ZyXEL Access Points. Other vendor cards work ok even if SSID is hidden.

  3. #3
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    452
    Hello,

    You are correct Pekka.

    This hidden SSID compatability is a non-standarded feature that is implemented several ways by AP manufacturers.

    Our latest PC SW has been improved this compatability and you should test this this Win XP Beta version if it worked.

    BR,

    Nokia D211 Support

  4. #4
    Registered User
    Join Date
    Aug 2003
    Posts
    3
    Dear Nokia D211 Support,

    Latest beta driver solved problem with ZyXEL AP's and hidden SSID.

    Do you have any schedule to release non beta version of this driver? How about other operating systems?

    Best Reagrds,
    Pekka Sakara

  5. #5
    Nokia Developer Expert
    Join Date
    Apr 2003
    Posts
    7
    Yep, I would like to hear about this driver upgrade as well.

    I Have tried several b&g standard access points on the market, and it seems that the D211 has problems with most when running the non beta 4.33 drivers. With some, you get D211 to work by disabling the g standard, but that is not really a feasible solution for a mixed environment.

    Are there any advanced settings one could try to play around with in the D211 Windows client software, that could help?

    Regards,

    Mikael Stendahl
    Radiolinja

  6. #6
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    452
    Hello,

    There are a few issues, which may cause problems with Nokia D211. Those are features that are not described in the IEEE802.11b standard. These issues have been discussed several times in this discussion board and here is a quick summary of them.

    If using Nokia D211 with ver. 4.33 drivers:

    Force 11Mbps speed if using a 22Mbps access point.
    Disable Hidden SSID feature in access point.
    Force 802.11b mode if using a 802.11g access point.

    The latest beta drivers for Win XP correct automatically the issues mentioned above.

    We are currently working on with further driver updates. We will post news on this board when new versions are available.


    Best Regards,

    Nokia D211 Support

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •