×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Regular Contributor
    Join Date
    May 2003
    Posts
    88

    File not created on the device?

    Hi,
    I am creating a file in my application...and it is working absolutely fine on the emulator..but while testing it on the device the file is not there.....paths are tested!!!
    help on this matter..

    regards
    techno2003

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167
    Hi

    Have you cheked ALL return values of all objects that are not leaving, one of then is propably reporting the error situation and when you find it you are a lot closer to find the cure as well.

    yucca

  3. #3
    Regular Contributor
    Join Date
    May 2003
    Posts
    88

    Which values are u talking abt?

    Hi,
    Which error values are u talking abt....do u mean errors related to file API or something else...

    but if it is there as u say,then how come it is running fine on emulator but not on the device....


    also i would like to tell u that the file which i am creating is being used in the same application for some processing...
    pls help urgently.....

    regards
    techno2003

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167
    Hi

    Just check all intitialization function involved in file creation, and check the return values of the against KErrNone and have some way to report errors back to you (error notes etc.) or just use User::LeaveIfError() and get system error notes on error situations.

    yucca

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×