×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Oct 2003
    Location
    Israel
    Posts
    17

    HTTP client on Symbian Series 60

    Hi!

    I've written C++ RSocket-based application like HTTP client for Symbian Series 60/6.1 that connects to my Tomcat HTTP Server. This application works properly in EPOC emulator, but doesn't work in Nokia
    7650 - it produces DNS and Connect errors. However, WAP access from the phone to the server works properly.

    Can anybody explain me what's the problem?
    Might be any definitions in the phone that forbid access to Internet?

    Thanks in advance, Irina.

  2. #2
    Registered User
    Join Date
    Aug 2003
    Location
    Oulu, Finland
    Posts
    1,122
    Do you have an internet access point (and not a WAP-only access point)? Ask your service provider for internet access point settings.

    Lauri

  3. #3
    Registered User
    Join Date
    Oct 2003
    Location
    Israel
    Posts
    17
    Hi, Lauri!

    Thanks for your reply.

    You are right - I've called to my provider and he explained me how to set internet access point.

  4. #4
    Registered User
    Join Date
    Aug 2003
    Location
    donetsk UA
    Posts
    22

    WAP-only access point ?

    Please contribute clarity.
    programs written on Java works with WAP access point (in my network wap works through GPRS) and http post/get works perfectly.
    can program on C++ use this access point? or i must use a real internet access point?

  5. #5
    ortiv
    Guest

    Irina, can you send me your code?

    Irina!

    I'd like to get an example program like your RSocket based http client for Series 60 platform. It's not problem for me if the application can appear on the emulator only. Can you send me your code example via e-mail or by other way? I'll be very thankful...

    Theo

  6. #6
    Registered User
    Join Date
    Feb 2004
    Posts
    1

    how to use HTTP Connection on symbian series60

    i tried to write an aplication that could help to connect to ras using a symbian phone but series 60 phone usein g symbian 6.0 doesnt seem to ahve http connection can any one mhelp me out wiht this problemmor tell em a pathc up of sort that coul help me ot connec to an RAS using my symbian series 60 phone
    or can any one tell me wht is the source code that must be used to connect to a RAS using a symbian phone having serise60 os
    thanking u in anticipation

  7. #7
    Regular Contributor
    Join Date
    Oct 2003
    Location
    Jakarta, Indonesia
    Posts
    53
    Hi tombrider, if you mean you want to make http connection and send http request to a server, you can modify socket example, by changing the RunL function on socketengine.cpp.
    before read funtion calls, you can put writeL function on it, which write the http request, such as "GET [url] HTTP/1.1\r\n...(other HTTP header)..\r\n\r\n".
    Before that you can change KDefaultServer to the IP address of your chosen server, and set the port to 8080.

    Hopefully this can answer your question.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×