×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Sep 2003
    Posts
    46

    What appears at phone when oma setting received

    Hello,
    when setting received it shows something like:
    Application: services
    start page: http://wap.xxx.yy
    Application: multimedia messages

    Why it is not shown the start page for the multimedia messages?
    is that normal?

    for w2 I have:

    <characteristic type="APPLICATION">
    <parm name="APPID" value="w2"/>
    <parm name="TO-PROXY" value="wappiproxy"/>
    <parm name="NAME" value="RL gprs"/>

    <characteristic type="RESOURCE">
    <parm name="URI" value="http://wap.radiolinja.fi"/>
    <parm name="STARTPAGE"/>
    </characteristic>
    </characteristic>





    and for w4 I have:

    <characteristic type="APPLICATION">
    <parm name="APPID" value="w4"/>
    <parm name="TO-PROXY" value="mmsproxy" />
    <characteristic type="RESOURCE">
    <parm name="URI" value="http://mmsc.xxx.yy" />
    <parm name="STARTPAGE"/>
    </characteristic>
    </characteristic>

  2. #2
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Tampere / Finland
    Posts
    1,839
    Hello!

    There is NO start page for MMS. MMS stands for Multimedia Messaging Service.

    Teemu / Forum Nokia

  3. #3
    Registered User
    Join Date
    Sep 2003
    Posts
    46
    OK,
    so,
    I have send the following setting xml file,
    it shows:

    Application: services
    start page: http://wap.xxx.yy
    Application: multimedia messages
    start page: https://mmsc.xxxx.yy


    ¡s this ok?
    should show start page for mms or not?

    thanks



    <?xml version="1.0"?>
    <!DOCTYPE wap-provisioningdoc PUBLIC "-//WAPFORUM//DTD PROV 1.0//EN" "http://www.wapforum.org/DTD/prov.dtd">
    <wap-provisioningdoc version="1.0">



    <characteristic type="NAPDEF">
    <parm name="NAPID" value="trMMS"/>
    <parm name="NAME" value="tr setting"/>
    <parm name="BEARER" value="GSM-GPRS"/>
    <parm name="NAP-ADDRESS" value="mms.zzzz.yy"/>
    <parm name="NAP-ADDRTYPE" value="APN"/>

    <characteristic type="NAPAUTHINFO">
    <parm name="AUTHTYPE" value="PAP"/>
    <parm name="AUTHNAME" value="xxxxx"/>
    <parm name="AUTHSECRET" value="yyyyy"/>
    </characteristic>
    </characteristic>



    <characteristic type="APPLICATION">
    <parm name="APPID" value="w4"/>
    <parm name="TO-NAPID" value="ttMMS" />
    <parm name="NAME" value="Operator MMS Server"/>
    <parm name="ADDR" value="http://mmsc.xxx.yyy" />
    </characteristic>

    <characteristic type="BOOTSTRAP">
    <parm name="NAME" value="Victor test2"/>
    </characteristic>

    </wap-provisioningdoc>

  4. #4
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Tampere / Finland
    Posts
    1,839
    Hi!

    The XML seems OK to me. As you can see there is no startpage defined for MMS application but a ADDR. Phone UI will display a "homepage" for MMS. This must be "localisation" issue.

    Teemu / Forum Nokia

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×