×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Oct 2003
    Posts
    3

    newline character w/ series60

    I'm trying to use the append method to add a newline "\n" to a form (ie. sb.append(object.getValueString()).append("\n"); ).

    This seems to work on all phones with the exception of Nokia Series60 phones. With the Series60 models, the newline is ignored and addition append statements appear on the same line as the first append statement.

    If anyone has any thoughts on how I might be able to resolve this issue, please let me know.

    Thanks!
    Greg

  2. #2
    Regular Contributor
    Join Date
    Jun 2003
    Location
    Hungary
    Posts
    414
    What kind of Item did you use? Where the newline disappears (within Item or between Items)?

    It is working for me (on 7650):
    Code:
    myForm.append(new StringItem("myString1\n","mySrting2 \n myString3"));

  3. #3
    Registered User
    Join Date
    Oct 2003
    Posts
    3
    I made a mistake in my original question. I am actually trying to append to a List (not a form). The sb in the original question is a StringBuffer. I am then appending the StringBuffer to a list. Unfortunately I cannot use the above suggestion with a StringItem because these can only be appended to forms. To clarify, my code is as follows...

    sb.append(object.getValueString()).append("\n");

    sb is StringBuffer that is appended to a List. The \n is not recognized on the 3650 Nokia model (this works on all other models that were tested). If anyone knows of a way around this problem that still makes use of a List, please let me know. Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×