×

Discussion Board

Results 1 to 15 of 15
  1. #1
    Registered User
    Join Date
    Nov 2003
    Posts
    5

    proxyport 5080 mms xml

    hi,

    how can i set the proxyport to "5080" in my mms ota-xml-configuration? all other ports (9201, 9202, 9203, 80, 8080) are working fine, but not the port "5080". my 6600 set it automaticly to port "0". i don´t know why.

    thanks for your help.

    dvda

  2. #2
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Tampere / Finland
    Posts
    1,839
    Hi!

    Are you talking about OTA 7.0 configuration or OMA Client provisioning 1.1 configuration?

    In case of OTA 7.0 there is no way to configure proxy or proxy port, OTA 7.0 proxy settings refers to WAP gateway as proxy. Nokia 6600 MMS client runs top of TCP/IP so there is no need for WAP gateway address, due this fact OTA 7.0 can't be used to configure 6600 MMS client fully.

    There should not be any problem to configure any four digit port number for HTTP proxy when using OMA CP 1.1.

    Teemu / Forum Nokia

  3. #3
    Registered User
    Join Date
    Nov 2003
    Posts
    5

    oma - ota - xml

    i´ve send it to my phone as xml-document via oma and ota. it works without problems on my sony ericsson p900 (the same symbian version). i think it was a bug in the 6600 software (v3.42.1).

  4. #4
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Tampere / Finland
    Posts
    1,839
    Could you provide me the XML you are using. Please, send it to messaging.smart@nokia.com and I have look into it...


    Teemu / Forum Nokia

  5. #5
    Registered User
    Join Date
    Nov 2003
    Posts
    5
    your mailadress is not available...


    "This is an automatically generated Delivery Status Notification.

    Delivery to the following recipients failed.

    messaging.smart@nokia.com"


    /

  6. #6
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Tampere / Finland
    Posts
    1,839
    H!

    Sorry, my mistake, working address is smart.messaging@nokia.com

    Teemu / Forum Nokia

  7. #7
    Registered User
    Join Date
    Jul 2003
    Posts
    24

    problem with port 8799

    Hi,

    I have a similar problem configuring the 6600. I am using OMA provisioning. I cannot set the port to 8799.

    I can set the port to 8080 on the 6600. I can set port 8799 on the 6220.

    My s/w version is V3.42.1 16-10-NHL-10

    My XML is below.

    <characteristic type = "PXLOGICAL">
    <parm name = "PROXY-ID" value = "192.168.251.150"/>
    <parm name = "NAME" value = "vodafone live!"/>
    <parm name = "STARTPAGE" value = "http://live.vodafone.com"/>
    <characteristic type = "PORT">
    <parm name = "PORTNBR" value = "8799"/>
    </characteristic>
    <characteristic type = "PXPHYSICAL">
    <parm name = "PHYSICAL-PROXY-ID" value = "PRX1"/>
    <parm name = "PXADDR" value = "192.168.251.150"/>
    <parm name = "PXADDRTYPE" value = "IPV4"/>
    <parm name = "TO-NAPID" value = "NAP1"/>
    <characteristic type = "PORT">
    <parm name = "PORTNBR" value = "8799"/>
    </characteristic>
    </characteristic>
    </characteristic>
    <characteristic type = "NAPDEF">
    <parm name = "NAPID" value = "NAP1"/>
    <parm name = "BEARER" value = "GPRS"/>
    <parm name = "NAME" value = "vodafone live!"/>
    <parm name = "NAP-ADDRESS" value = "live.vodafone.com"/>
    <parm name = "NAP-ADDRTYPE" value = "APN"/>
    <characteristic type = "NAPAUTHINFO">
    <parm name = "AUTHTYPE" value = "PAP"/>
    <parm name = "AUTHNAME" value = "vodafone"/>
    <parm name = "AUTHSECRET" value = "vodafone"/>
    </characteristic>
    </characteristic>
    <characteristic type = "APPLICATION">
    <parm name = "APPID" value = "w2"/>
    <parm name = "NAME" value = "vodafone live!"/>
    <parm name = "TO-PROXY" value = "192.168.251.150"/>
    <characteristic type = "RESOURCE">
    <parm name = "URI" value = "http://live.vodafone.com"/>
    <parm name = "STARTPAGE"/>
    </characteristic>
    </characteristic>

  8. #8
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Tampere / Finland
    Posts
    1,839
    Hi!

    Yes, this is known problem now and will be fixed for next software release of Nokia 6600.

    Teemu / Forum Nokia

  9. #9
    Registered User
    Join Date
    Jul 2003
    Posts
    24
    Hi,

    am I right to assume that the only port that can be configured before the new software release is 8080?

    Thanks

    Sean.

  10. #10
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Tampere / Finland
    Posts
    1,839
    Hello again!

    No, ports available are: 80, 8080, 9200-9203

    Teemu / Forum Nokia

  11. #11
    Registered User
    Join Date
    Jul 2003
    Posts
    24
    Hi auvinent,

    thanks for the info.

    Sean.

  12. #12
    Registered User
    Join Date
    Feb 2004
    Posts
    5
    Hello again!

    No, ports available are: 80, 8080, 9200-9203

    Teemu / Forum Nokia
    Hi
    You say that in the current software release one cannot set a different proxy port, other than 80,8080,9200-9203..
    I have a Nokia 6600 with that software version and using an SMS gateway for testing I verify this bug. But if I go to the Nokia configuration URL http://www.nokia.com/nokia/0,6771,53589,00.html I'm able to correctly configure my phone to use the Vodafone Portugal settings, which use the 5799 port!
    Do you have any explanation for this? I think this proves you can do it programatically...

  13. #13
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Tampere / Finland
    Posts
    1,839
    Hi!

    Ok, my list of available ports may havo not beex exclusive, there might be a another ports that can be configured, but the point is not all are.

    As mentioned earlier new software release will fix this.

    Teemu / Forum Nokia

  14. #14
    Registered User
    Join Date
    Mar 2003
    Posts
    6
    I had the same problem when using 'non-standard' port number for Nokia 6600. This problem can be avoided by
    adding a SERVICE parameter to the PORT characteristic so it looks like this:

    <characteristic type="PORT">
    <parm name="PORTNBR" value="5080"/>
    <parm name="SERVICE" value="CO-WSP"/>
    </characteristic>

    Thanks
    Saurabh

  15. #15
    Registered User
    Join Date
    Feb 2004
    Posts
    5
    spunjabi:
    exactly! that's what I found out by trial and error about 1 hour after I sent my previous post... it's mentioned in the DP_2_0_for_Series_60_OMA_Client_Provisioning_v1_0_en.pdf
    document that if you use non-standard ports you have to use the <SERVICE> tag!
    If you do this, I think you can use any port, so the bug is not really a bug.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×