×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Dec 2003
    Location
    Australia/Malaysia
    Posts
    29

    HTTP massive header received

    Hi all,

    Got a tricky question here and i am getting desparate for some pointers. Here it goes.

    Ok, i'm writing an app targeted for all phones that is MIDP 1.0 compatible. I was testing out the basic HTTP connection between the client (mobile app on the phone) and server (standard J2SE server application). The app is to establish a standard HTTP connection and a POST header set. Then, data in bytearray is sent to the server. The connection will be established using GPRS.

    I find that there are vast differences between running the app on the emulator, Nokia phones and other phones. The actual stuff received on the server varies, which might be due to the different MIDP layer on the phones.

    The problem is that running the simple test on the Nokia 3100 phone produces vastly bigger headers than using other phones such as a Sony-Ericsson T610. Besides that, it is weird to see that the headers are extras that was not set by the test app. The fact that i only set the httpconnection.POST method and nothing else.

    The information received includes:
    MIDP/CONFIG version, host ID, up-link, up-link fax, application postscripts, WAP settings and all these stuff.

    I initially sent about 80bytes of data but ended up with around 1kilobyte of data, fatal for the app i'm gonna write. For other actual phones, i get various results as well. But the variation comes from the POST method i set. The Sony-Ericsson sent information such as transfer encoding and host ID to the server before the actual pay load, a massive reduction in comparison to the Nokia 3100.

    Since both the test on different mobile phones used the same sim card (Telstra austalia), i dun think its the telco doing this. The only thing i can think of is the MIDP layer. So, is there any way of "turning off" these headers and eliminating these things being sent to the server?

    And another thing, is there any Nokia SDKs for the Nokia 3100?

    Thnx heaps.

  2. #2
    Registered User
    Join Date
    Nov 2003
    Posts
    11
    I have the same problem with 3510i .
    It sends a huge header also, and there is nothing you can do about it. Unfortunately

  3. #3
    Registered User
    Join Date
    Dec 2003
    Location
    Australia/Malaysia
    Posts
    29
    Have u tried using different telco and/or different gateway? I heard that it is due to the headers appended by the wap gateway or could be the firmware itself. If its the gateway, then i suppose we cant do anything about it, and if we dun pay for those extra stuff(headers) that i its all good.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×