×

Discussion Board

Results 1 to 6 of 6

Thread: ActivePerl

  1. #1
    Registered User
    Join Date
    Dec 2003
    Posts
    4

    ActivePerl

    I'm trying to install the SDK for the Series 60 7.0 v2.0. It requires the Java Runitime Environment (which I've installed) and ActivePerl 518 or newer. I've downloaded and installed ActivePerl 633 from ActiveState.com, however when I go to install the SDK it still says I need ActivePerl 518 or newer. I don not know why it is not recognizing the ActivePerl. I tried to ignore it and installed the SDK, however after attempting to load the first HelloWorld demo I've received errors during the load. They are "not recognized as an internal or external command" and "system cannot find file specified" errors which I receive at the command prompt after running (abld build wins udeb) command. I'm assuming I can attribute these erros to the ActivePerl problem because I'm going by the book here, these examples are already written and I'm simply following instructions to load them. Help?

    I've also tried the abld freeze command prior to this, it gives me errors as well.

    BELOW ARE MY ERRORS WHEN I TYPE THE COMMAND

    C:\Symbian\7.0s\Series60_v20\Examples\helloworld>abld build wins udeb
    make -r -f "\Symbian\7.0s\Series60_v20\EPOC32\BUILD\SYMBIAN\7.0S\SERIES60_V20
    \EXAMPLES\HELLOWORLD\EXPORT.make" EXPORT VERBOSE=-s
    Nothing to do
    make -r -f "\Symbian\7.0s\Series60_v20\EPOC32\BUILD\SYMBIAN\7.0S\SERIES60_V20
    \EXAMPLES\HELLOWORLD\WINS.make" MAKEFILE VERBOSE=-s
    perl -S makmake.pl -D \SYMBIAN\7.0S\SERIES60_V20\EXAMPLES\HELLOWORLD\HELLOWORLD
    WINS

    MMPFILE "\SYMBIAN\7.0S\SERIES60_V20\EXAMPLES\HELLOWORLD\HELLOWORLD.MMP"
    WARNING(S)
    \SYMBIAN\7.0S\SERIES60_V20\EXAMPLES\HELLOWORLD\HELLOWORLD.MMP(20) : SYSTEMINCLUD
    E path "\Symbian\7.0s\Series60_v20\EPOC32\INCLUDE\TECHVIEW\" not found

    'LINK.EXE' is not recognized as an internal or external command,
    operable program or batch file.
    ERROR: failed to find version information for LINK.EXE
    make: *** [MAKEFILEHELLOWORLD] Error 2
    make -r -f "\Symbian\7.0s\Series60_v20\EPOC32\BUILD\SYMBIAN\7.0S\SERIES60_V20
    \EXAMPLES\HELLOWORLD\WINS.make" LIBRARY VERBOSE=-s
    nmake -nologo -x - -s -f "\Symbian\7.0s\Series60_v20\EPOC32\BUILD\SYMBIAN\7.0S\
    SERIES60_V20\EXAMPLES\HELLOWORLD\HELLOWORLD\WINS\HELLOWORLD.WINS" LIBRARY
    process_begin: CreateProcess((null), nmake -nologo -x - -s -f \Symbian\7.0s\Seri
    es60_v20\EPOC32\BUILD\SYMBIAN\7.0S\SERIES60_V20\EXAMPLES\HELLOWORLD\HELLOWORLD\W
    INS\HELLOWORLD.WINS LIBRARY, ...) failed.
    make (e=2): The system cannot find the file specified.
    make: *** [LIBRARYHELLOWORLD] Error 2
    make -r -f "\Symbian\7.0s\Series60_v20\EPOC32\BUILD\SYMBIAN\7.0S\SERIES60_V20
    \EXAMPLES\HELLOWORLD\WINS.make" RESOURCE CFG=UDEB VERBOSE=-s
    nmake -nologo -x - -s -f "\Symbian\7.0s\Series60_v20\EPOC32\BUILD\SYMBIAN\7.0S\
    SERIES60_V20\EXAMPLES\HELLOWORLD\HELLOWORLD\WINS\HELLOWORLD.WINS" RESOURCEUDEB
    process_begin: CreateProcess((null), nmake -nologo -x - -s -f \Symbian\7.0s\Seri
    es60_v20\EPOC32\BUILD\SYMBIAN\7.0S\SERIES60_V20\EXAMPLES\HELLOWORLD\HELLOWORLD\W
    INS\HELLOWORLD.WINS RESOURCEUDEB, ...) failed.
    make (e=2): The system cannot find the file specified.
    make: *** [RESOURCEHELLOWORLD] Error 2
    make -r -f "\Symbian\7.0s\Series60_v20\EPOC32\BUILD\SYMBIAN\7.0S\SERIES60_V20
    \EXAMPLES\HELLOWORLD\WINS.make" TARGET CFG=UDEB VERBOSE=-s
    nmake -nologo -x - -s -f "\Symbian\7.0s\Series60_v20\EPOC32\BUILD\SYMBIAN\7.0S\
    SERIES60_V20\EXAMPLES\HELLOWORLD\HELLOWORLD\WINS\HELLOWORLD.WINS" UDEB
    process_begin: CreateProcess((null), nmake -nologo -x - -s -f \Symbian\7.0s\Seri
    es60_v20\EPOC32\BUILD\SYMBIAN\7.0S\SERIES60_V20\EXAMPLES\HELLOWORLD\HELLOWORLD\W
    INS\HELLOWORLD.WINS UDEB, ...) failed.
    make (e=2): The system cannot find the file specified.
    make: *** [TARGETHELLOWORLD] Error 2
    make -r -f "\Symbian\7.0s\Series60_v20\EPOC32\BUILD\SYMBIAN\7.0S\SERIES60_V20
    \EXAMPLES\HELLOWORLD\WINS.make" FINAL CFG=UDEB VERBOSE=-s

    C:\Symbian\7.0s\Series60_v20\Examples\helloworld>
    Last edited by geot@fb-4.com; 2003-12-26 at 16:23.

  2. #2
    Registered User
    Join Date
    Mar 2003
    Location
    Bangalore, India.
    Posts
    13
    Try to add the bin directory of Active perl in the environment variables as follows.

    C:\Perl\bin\;

    If you have doubts in setting environment variables, please refer the following thread.

    http://discussion.forum.nokia.com/fo...threadid=27421

    Regards,
    Nagaraj.

  3. #3
    Registered User
    Join Date
    Dec 2003
    Posts
    4
    I've added C:\Perl\bin to the path. I was able to load the demo just fine with a command line build. However the build did give some errors. It didn't seem to affect the program though....Thanks

  4. #4
    Registered User
    Join Date
    Jul 2010
    Posts
    1

    Re: ActivePerl

    I am having the same problem. The exact errors same with geot@fb-4.com appear when I typed the command. I must have missed something when I Installed the SDK. It does recognize perl. We need help out here.
    Nate Digby
    www.creditcard.net.ph

  5. #5
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: ActivePerl

    Quote Originally Posted by natedigby21 View Post
    I am having the same problem. The exact errors same with geot@fb-4.com appear when I typed the command. I must have missed something when I Installed the SDK. It does recognize perl. We need help out here.
    are you using same SDK as of "geot...com" and can you check your PATH variable for perl\bin

  6. #6
    Regular Contributor
    Join Date
    Apr 2010
    Location
    Surat, India
    Posts
    277

    Re: ActivePerl

    Quote Originally Posted by natedigby21 View Post
    I am having the same problem. The exact errors same with geot@fb-4.com appear when I typed the command. I must have missed something when I Installed the SDK. It does recognize perl. We need help out here.
    I was also having some problem with latest version of active perl. It was 5.10 at my time. So I downloaded an old version "ActivePerl-5.6.1.629-MSWin32-x86-multi-thread.msi" which solved my problem. Just search out for the download link, I don't have currently. Also make sure it is in your PATH variable. You can set PATH variable if it is not set already
    Thanks,
    Rahul Kulshreshtha
    Please choose Notification type as "Instant Email Notification". It must be default.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×