×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Jan 2004
    Posts
    2

    Build problem in VC environment

    Hello

    I am a beginner using Symbian. I am having problem building my first application. It's giving error .RSG file not found. Can any one tell me what this file is? When I created work space using abld makefile VC6 command the workspace is created in a different path. Please help.

    Regards
    Sakshi

  2. #2
    Regular Contributor
    Join Date
    Mar 2003
    Location
    UK
    Posts
    159
    IIRC, the .rsg is a generated file, and VC doesn't always build all these generated files for you. Best thing is to do a "abld build wins udeb" from the command line - this should create the file for you. From then on you can use VC as you'd expect.

    As for where the project file gets created - you just have to get used to navigating the symbian file tree down the epoc32/BUILD directory... (you'll also get used to finding the epoc.exe file in the epoc32/release/wins/udeb directory for running the emulator from VC, and the epoc32/wins/c direcotry which is the c: drive of the emulator, and so on...)


    Cheers
    Russell

  3. #3
    Registered User
    Join Date
    Jan 2004
    Posts
    2
    Hello

    Thanks for the reply, I tried building it from command prompt using abld build wins udeb and in release mode as well but I am getting an NMAKE error. Can you tell me how to rectify this?

    Thanks and Regards
    Sakshi

  4. #4
    Registered User
    Join Date
    Jan 2004
    Posts
    1
    I also have the same problem to compile helloworld. And don't know how to solve it till now :( Anyone had the same problem too? what is the name of program for compiling resources?

    i notice that the process freeze when executing:

    nmake -nologo -s -f "\Symbian\6.1\Series60\EPOC32\BUILD\SYSMBIAN\6.1\SERIES60\EPOC32EX\HELLOWORLD\HELLOWORLD\WINS\HELLOWORLD.WINS" RESOURCEUDEB
    Last edited by soberanz; 2004-01-16 at 08:01.

  5. #5
    Nokia Developer Expert
    Join Date
    Apr 2003
    Location
    Finland
    Posts
    425
    Check this thread throw...I think the resource compilation dosen't succeed becase the environment isn't correctly installed.

    http://discussion.forum.nokia.com/fo...nmake+error%2A

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×