×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Jan 2004
    Posts
    7

    hosting a j2me app

    Hello,

    I was wondering how I package a j2me application so that I can host it on my website. I have a simple hello world app (have jad and jar files) . do I simply host these in a site and point my phones browser at the jar file ?

    thanks,

    Ken.
    Last edited by ken_c; 2004-01-19 at 14:33.

  2. #2
    Regular Contributor
    Join Date
    Mar 2003
    Location
    Indonesia - East Java
    Posts
    128

    solustions

    dear,

    you can make W@P application that link would link at your jad application name.

  3. #3
    Registered User
    Join Date
    Jan 2004
    Posts
    7

    hosting a j2me app

    Thanks for the help. Still having trouble however.

    I have created a simple WAP page :

    <?xml version="1.0"?>
    <!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN"
    "http://www.wapforum.org/DTD/wml_1.1.xml">

    <wml>
    <card title="A Tag"><p>
    <a href="Boids.jad">download</a>
    </p></card>
    </wml>


    It is hosted on a web server . I have placed the wml page, the jad and the jar files in a folder called wap. THe wap page opens fine on my phone but when I click on the download link the contents of the jad file are displayed on screen and nothing else happens ?
    Here is the jad file, the sample one with the nokia developer suite.

    MIDlet-Name: Boids
    MIDlet-Version: 1.0.5
    MIDlet-Vendor: Forum Nokia
    MIDlet-Jar-URL: Boids.jar
    MIDlet-Jar-Size: 9932
    MIDlet-Description: Boids MIDlet
    MIDlet-Icon: /boids.png
    MIDlet-1: Boids, /boids.png, example.boids.BoidsMIDlet

    Am i doing something wrong ? Tried using a Siemens C60 and a Nokia 3300.

    Thanks again for the help.

    Ken.

  4. #4
    Registered User
    Join Date
    Jan 2004
    Posts
    7
    just an update,

    my nokia 3300 is displaying an error message when I click to the link to my jad file :

    File Format Unknown.

    my siemens c60 on the other hand just displays the jad file contents on screen
    Last edited by ken_c; 2004-01-19 at 14:38.

  5. #5
    Regular Contributor
    Join Date
    Mar 2003
    Location
    Moscow/Russia
    Posts
    258
    Try to use UTF-8 encoding for wml files

  6. #6
    Registered User
    Join Date
    Jan 2004
    Posts
    7
    I have included the utf encoding option but it has not solved the problem. The wml page is opening okay. When I click the link to download the application it throws up the Unknown File Format error.
    Is the problem due to the way my jad is linked using the wml page ?
    I am downloading the application using the Application submenu on the 3300. I have created a bookmark, entered the location of the wml file and saved that bookmark to both the Application Download and Game Download menus.

    I really need to solve this asap. There must be an easy explanation to this.

    I have tried using my 3300's DKU cable but the phone is not being detected by the developer kit when i attempt to deploy . I have downloaded a nokia driver for the dku cable but that hasn't solved the problem either. I'm running XP.

  7. #7
    Super Contributor
    Join Date
    Jun 2003
    Location
    Cheshire, UK
    Posts
    7,395
    Your web server is not transmitting the correct types for JAD and JAR files. The correct MIME types are:

    .jad - text/vnd.sun.j2me.app-descriptor

    .jar - application/java-archive

    The type code is transmitted by the web server in the header for each response - this is how the receiver knows how to process the content (so your web browser usually receives "text/html" or "image/jpeg", for example). Without the correct type for JAD and JAR files, the phone won't know that it's receiving an application, so won't realize that it has to install something.

    How these are configured depends on your server... you may need to contact your server's administrator to do this for you. Alternatively, someone did post a trick for getting around this using a PHP script... read http://discussion.forum.nokia.com/fo...threadid=30438.

    Graham.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •