×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Mar 2003
    Location
    Stockholm, Sweden
    Posts
    30

    Nokia 3200 reboots on certain XHTML pages

    I have noticed that the Nokia 3200 reboots when I'm trying to view certain (valid) XHTML MP pages. The thing that I have come to think of is that the pages that causes this contain absolute URL:s to images that reside on a different server (like <img src="http://www.myserver.com/picture.gif" alt="" /> ). I have several such images and they all work nicely...unless on these particular pages where the access to the images is restricted (by HTTP basic authentication).

    Is this a known issue with the N3200? Or am I totally off target while accusing the password protected images? Is there another issue here that I'm missing?

    The password will be removed once in production, so it would be nice to know that everything will work in real life and that I can ignore this for now...or if I would need to allocate resources to address this problem.


    Best regards,
    Rasmus

  2. #2
    Registered User
    Join Date
    Mar 2003
    Location
    Stockholm, Sweden
    Posts
    30
    It seems like it was the pictures stored on a password protected server that was the problem. As we now have gone live (without password protection) with our service, the 3200 works just fine...

    Nokia: this might be an annoying problem for developers. Solve it to your next S40 model...

  3. #3
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    466
    Hi,

    could you let me know the software version of your phone? I&acute;d like to test this myself on same device and software.

    Satu

  4. #4
    Registered User
    Join Date
    Mar 2003
    Location
    Stockholm, Sweden
    Posts
    30
    How can I tell of what version our N3200 is? I know there's a code for it, but I forgot it.. :)

  5. #5
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    466
    Try *#0000#.

    Satu

  6. #6
    Registered User
    Join Date
    Mar 2003
    Location
    Stockholm, Sweden
    Posts
    30
    Ok, the display says:

    V a3.08
    11-10-03
    RH-30
    3200
    (c) Nokia

  7. #7
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    466
    Hi,

    we haven&acute;t been able to reproduce the problem. Could you let me know the URL to your site which causes crashing? We&acute;d like to take a look the XHTML code.

    -Satu

  8. #8
    Registered User
    Join Date
    Mar 2003
    Location
    Stockholm, Sweden
    Posts
    30
    Sorry, these pages are on our development server so I can't give you access to that.

    Here's how to reproduce it:

    1. create a page on a password protected site (with basic auth)
    2. let that page contain images that in turn reside on ANOTHER, password protected, site.
    3. go to the page with the 3200

    Normally, the phone would ask for a login/password for every password-protected image (the first time the page is loaded, that is. After that, the password is cached). But the 3200 just reboots before asking for login/password...
    Last edited by deeper; 2004-02-03 at 08:35.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •