×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    5

    coded the menu but doesn't appear

    Hi,

    I have a very confusing problem:

    I programmed the menu in the test.rss-file.

    but when i compile it you cant open the menu although the options-"button" is displayed.

    it works neither with the emulator nor with my mobile.

    But the helloworldplus-example works. and I cant find any "real" difference between the example and my program.

    Thanks in advance
    Dennis

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,165
    hi

    Have you defined correct menubar in your EIK_APP_INFO struct. The struct can be found from the top of your RSS file. And be sure you define a menubar there, not a menu pane.

    yucca

  3. #3
    Registered User
    Join Date
    Mar 2003
    Posts
    5
    yes i have the right entries in my .rss-file:

    menubar = r_example_menubar;
    and
    cba= R_AVKON_SOFTKEYS_OPTIONS_EXIT;

    the most interesting thing is, is you let your program print a message when you press the options_softkey it works, but also without menu. i don'T know what i've done wrong.

    could it be that the applivation and view classes must be derived from CAknApplication ? or from CEikApplication.
    or do i have to include some fun´ction to display the menu?

    Thanks for your help

    Dennis

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,165
    yep,

    Basically if you have CAknView derived view class, then you should always have CAknViewAppUi derived appui-class, the application & document classes can be same as they are with the system without the CAknView derived classes.

    Could you also check that you are calling the BaseConstructL() in AppUi classes constructor, and that you are activating all of your containers.

    In case they dont still work, just check what's really different with the helloworld example and try making those changes to find your error.

    yucca

  5. #5
    Registered User
    Join Date
    Mar 2003
    Posts
    5
    Thanks.
    Now it works but i had to copy the whole helloworldstuff into my new project. whats a project template good for if the simplest things like a menu doesn't work?
    so thanks a lot

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×